90% memory usage


  • Posts: 1
I have this problem and I tried with the .bat solution (java -Xms64m -Xmx3072m -jar sw.jar) but dont solve the problem , the cmd disappears at moment


  • Posts: 9
Hola PezDeGoma, I have the same issue you have.  Sometime ago I was using the .bat solution and it was working fine but since a couple of weeks ago whenever I run the .bat file the cmd window opens and closes immediately and Stencyl doesn't open so I still run with the 90% memory issue.
I think it might be related to the Java version but not so sure.

Anyone has any idea why this happens and how to solve it?



  • Posts: 9
Thanks dareek, that thread has a lot of useful information.
I've actually just figured out what the problem was and I've solved it.
@PezDeGoma: I am gonna shared what I've done and maybe is the same issue you have and hopefully it will help you.
As the cmd window was closing too quickly I couldn't see what was going on so I opened the cmd myself and executed the code you have in the .bat file, see screenshot attached.
The error was that it wasn't finding the necessary file to run it, so I went to download the jre7 http://www.oracle.com/technetwork/java/javase/downloads/java-se-jre-7-download-432155.html
after I installed it I verified that the file was in the location indicated in the error message "c:\Program Files\Java\jre7\lib\amd64\jvm.cfg" and then I run the .bat file with no issues.

Please let me know if it is clear, and also just check what's the error message you see in the command window as it could be just different from my case.