Player does not stop in HTML5

yogyog

  • Posts: 24
Hello there....

I wander if anyone has an answer for this...

I've made a game originally working in Flash, but converting to HTML5 last minute as the client wanted this.

While every everything else seams to be working - the player does not stop moving!

This is a little room to test the controls - not the whole game.  Export HTML5 is greyed out - probably cos I've gone through deleting sound effects - but I can still test HTML5.  Everything seems to be working, but the character does not stop when you let go of the button.

The control is based on the default platformer, but with a sward action added.

If this is a big job to fix I am willing to pay.

colburt187

  • *
  • Posts: 2373
The issue seems to be the ground slowdown value in the slowdown behaviour is too low, its 0.2 and should be 0.9 or higher.

yogyog

  • Posts: 24
Thankyou, but I've now brought the slowdowns up to 4 across the board, and I'm having exactly th e same problem.

Also  -  I tried the stencyl kit I started with: on that I get no charactor movement at all...


yogyog

  • Posts: 24
Thank you, but I've looked at the logic blocks for the Slowdown behaviour... it multiplies the X-velocity by the factor, so a lower number will mean it slows down quicker.

I also checked to see if HTML5 can read a button being unpressed - and it can - so it's not that.

Next stage - see if the  slowdown behaviours are even being triggered...

colburt187

  • *
  • Posts: 2373
what happens if you set the slowdown to 0.9?

colburt187

  • *
  • Posts: 2373
hmm this is a strange one, when i tested in flash it wouldn't stop as so suggested. but now in flash and HTML5 it slows down correctly even on 0.2 slowdown.

What happens if you change the material of the player from ice to wood?

colburt187

  • *
  • Posts: 2373
This is a strange one, I don't think its an HTML5 but and i don't think its an error in the logic. I suspect its some sort of bug cased when updating to 4.0 from an older stencyl version.

For me the sliding issue fixes itself once i open the slow down behaviour and then test the scene.

yogyog

  • Posts: 24
Thanks for your help.  I ended up adding this to the character.