OutOfBoundsException

JeffreyDriver

  • *
  • Posts: 2163
Unexpected problem on thread AWT-EventQueue-0: java.lang.IndexOutOfBoundsException: Index: 9, Size: 0

I keep getting this error and I've tracked it down to a particular actor. Except for the graphic, the actor is identical to dozens of others, and it's not a large image. There are others which are larger and smaller. Even if I delete the actor and try to recreate it, it happens again. Really confused.

Recreating the scene/actor and even using a different actor is causing the problem. Clearing the cache and rebuilding hasn't solved it either.
Current Projects:
The Grand Grimoire Chronicles Episode 1 now on Kongregate!.
I always appreciate useful feedback. Thank you.
www.jeffreydriver.co.uk

JeffreyDriver

  • *
  • Posts: 2163
Still no closer to solving this. Recreating the actor with different names isn't even working. Some things I don't get are in the logs. It mentions missing actors, but the actors are there. Only deleting them will let me open the particular scene.

Could not parse "". Defaulting to: 0. stencyl.sw.editors.behavior.SnippetSheet.createVariableField (line: 789)

Could not load actor. Likely an Actor Type that no longer exists.
Actor "Window One Light Copy 15" does not refrence an Actor Type: id = 503

Could not parse "". Defaulting to: 0. stencyl.core.engine.snippet.IVariable.getRealValue (line: 317)

Unexpected problem on thread AWT-EventQueue-0: java.lang.IndexOutOfBoundsException: Index: 9, Size: 0

Current Projects:
The Grand Grimoire Chronicles Episode 1 now on Kongregate!.
I always appreciate useful feedback. Thank you.
www.jeffreydriver.co.uk

Electric Fruit

  • *
  • Posts: 115
Hi Jeffrey

The "Unexpected problem on thread AWT-EventQueue-0: java.lang.IndexOutOfBoundsException: Index: 9, Size: 0" error and the issue you are having with scenes sounds similar to this error that was kicking around a while ago.

http://community.stencyl.com/index.php/topic,58331.msg307112.html#msg307112

It was fixed in the private release but I'm not sure what happened with the public one. Which build are you using

JeffreyDriver

  • *
  • Posts: 2163
Thanks. I'm on 10300 which I think is the latest public build. I did find some info on the error, but not a fix. Not ready to buy a license yet so I guess I have to wait.
Current Projects:
The Grand Grimoire Chronicles Episode 1 now on Kongregate!.
I always appreciate useful feedback. Thank you.
www.jeffreydriver.co.uk