offical help guide for linux install fails, 2016, need 2020 steps

wallydstencyl

  • Posts: 1
I'm a teacher who needs documentation on steps to install Stencyl on Linux.  The only hardware we have are old laptops they can run many linux distros.  ( see the linux versions I'm able to install listed below )

http://www.stencyl.com/help/view/install-stencyl-linux/

These steps above.   They do not work in 2020. The steps were authored in 2016. I've searched for a clear set of steps. I am currently running a classroom that has very little budget. We can install the following linux distros on our hardware: Mint current version, Ubuntu 18 or Xubuntu 18 or current version of MX Linux which is fast and lightweight. I'd appreciate if someone can document the steps for any one of these Linux distributions.

notes: one of the errors I get is pasted below:

run command: sudo apt-get install oracle-java8-installer
see results fail on screen as follows:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package oracle-java8-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Justin

  • *
  • Posts: 4504
Try installing AdoptOpenJDKs distribution instead of Oracle's.

If their guide doesn't work, this blog post may be helpful.


I can take a look at the setup guide, but it'll take some time before I can get to it.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

Justin

  • *
  • Posts: 4504
Okay, I went ahead and tried this out.

- Installed Linux Mint
- Ran suggested updates by the OS
- Downloaded and opened Stencyl (extract .tar.gz, double-click the "Stencyl" file, select "Run")

At this point, I was able to test both Flash and HTML5 games in Stencyl. Perhaps this is enough for your use of Stencyl in the classroom. If it is, you don't need to do anything more. If you want to unlock more of the targets, you'll need to install some components through the terminal.

To test on Native Linux, Cppia, and Android, you need to install the c++ development packages, same as written in the guide.

Code: [Select]
sudo apt-get install g++ libgc-dev libxext-dev
To publish HTML5 games, and to test on Android, you also need the JDK. I followed the first link I sent you step by step, and it worked fine, so you can probably ignore the second link I posted.

(Note: You can pick whatever version of the jdk you want. 8, 11, and 13 should all work fine.)

Code: [Select]
wget -qO - https://adoptopenjdk.jfrog.io/adoptopenjdk/api/gpg/key/public | sudo apt-key add -
sudo add-apt-repository --yes https://adoptopenjdk.jfrog.io/adoptopenjdk/deb/
sudo apt-get update
sudo apt-get install adoptopenjdk-11-hotspot

Set the path to the JDK at File > Preferences > Tools > JDK to the following:
Code: [Select]
/usr/lib/jvm/adoptopenjdk-11-hotspot-amd64
You can probably ignore all of the 32-bit support packages the guide mentioned. That is, everything in steps 2 and 3.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)