Problems installing on Linux


  • Posts: 24
Hi -

I found out about Stencyl by playing a Flash game made with it.  Looks great!

But I can't run it on Linux (ubuntu 11.10)

I download it and click the file Stencyl it doesn't do anything.  By running this file from command line I get the message "./runtimes/jre-linux/bin/java: No such file or directory"

Do I need to install Java first?


  • *
  • Posts: 6108
You don't need to install java. Stencyl comes with a bundled Java runtime environment since 2.0. It's strange that the ./runtimes/jre-linux/bin/java file is missing for you. Maybe your download was corrupted?


  • Posts: 24
I downloaded again ... the file ./runtimes/jre-linux/bin/java is there, and set to executable, but... still not working.


  • Posts: 725
Free Time:
Monday, Wednesday, Friday: 13h
Tuesday, Thursday, Saturday, Sunday: 7h
Loving Linux...


  • Posts: 19
Bump.  I'm having the same issue in Ubuntu 12.04.

logs cannot be generated when the program cannot even open, so I don't know why that was suggested.


  • Posts: 19

I run a 64 bit version of Ubuntu 12.04, so here's what I had to do:

sudo apt-get install ia32-libs

ia32-libs is a package containing runtime libraries for 32-bit architectures that have been configured for use on 64-bit kernels.  It's 245 megabytes.

Once I installed that package I was able to run Stencyl.


  • *
  • Posts: 6108
Oh, sorry, your right about the logs :-[ I must have been half asleep when I asked for them.

Thanks for sharing the solution. :)


  • Posts: 1
You don't need to install the ia32-libs, you only need to edit a bash file changing the route of java binaries like in this example.


./runtimes/jre-linux/bin/java -Xms64m -Xmx1024m -Djava.library.path=./lib -jar ./sw.jar


java -Xms64m -Xmx1024m -Djava.library.path=./lib -jar ./sw.jar

In this case, Stencyl use the local java installed in the OS.


To see what is your java version installed use the next command:

$java -version

To switch between various java version installed use:

$sudo update-alternatives --config java

and last one to install the new Oracle-java7 in ubuntu 12.04 you can follow the next link: