<MISSING STRING> error

alcas

  • Posts: 28
Every time i open stencyl up there are no strings. its just a bunch of missing strings. ive tried almost everything on the forums and no one actually gives an explanation of a clear cut solution. the topics die off and no one cares. how do i fix this error???

coleislazy

  • *
  • Posts: 2607
1. Make a backup copy of your games. You can find the games folder by clicking "View Games Folder" in the lower-left corner of Stencyl when no games are open. Simply copy the entire "games" folder somwehere safe (such as your desktop).
2. In the same directory as your "games" folder, there is a "prefs" folder. Delete it.
2. Uninstall Stencyl.
3. Delete any instances of StencylWorks.prefs on your computer. You may need to use your operating system's search feature to find it. It varies by OS.
4. Download and install the latest version of Stencyl here.
5. Run Stencyl, change your workspace if desired, then copy your "games" folder back to the workspace.
6. Make games!

alcas

  • Posts: 28
redownloaded it 16 times. its still not working.... is there any files i could specifically replace or something?

Joe

  • *
  • Posts: 2480
Can we get some more information about your setup? (OS, Java version, etc.) Are you using the stable build of Stencyl 2.0?

coleislazy

  • *
  • Posts: 2607
The important part isn't downloading the installer over and over. If you got the latest version, there's no need to keep getting it. The important part is making sure all traces of the previous version is removed. Are you sure you deleted the "prefs" folder and any copy of StencylWorks.prefs on your computer (there may be more than one if you used older versions of the software)?

alcas

  • Posts: 28
java version 1.6.0_30
windows XP service pack 3
Stencyl 2.0
Well i did delete all the files last time but i have never downloaded a new version. because i just started. ive only downloaded 1 downloader.

Joe

  • *
  • Posts: 2480
Are you performing the installation as an administrator user?

asifhs

  • Posts: 4
I have the following system:
Ubuntu 12.04 (64-bit)

I extracted Stencyl into a directory owned by me.
Executed Stencyl (which is a bash script).
Starts ok, but all the button labels are "Missing String".
Cannot figure it out.

Thanks for your help!

testlabinc

  • Posts: 3
I found the same thing happens when i export my game to desktop, then open it by the newly created file of the desktop and it loads stencil but when program loads its got missing strings all where text would be on the program, but when I open stencyl by application.exe it opens stencyl fine no missing strings but No game like BUG.. :o
COMING-S00n,

Fire Fox

  • Posts: 8
I have the exact same issue. Started as soon as I downloaded Stencyl 2 days ago (no previous versions on the computer). I've never been able to open an exported game without the [MISSING] errors, but the games play fine if I open Stencyl first and then test them. Very odd!