ENABLE behaviour is not working on IOS.

mbenin

  • Posts: 13
Hi!

It's only for me or the ENABLE/DISABLE behaviour isn't working for IOS ?

On WHEN CREATED block, i disable behavior A from behavior B. Ok, works like a charm.

But on the ALWAYS block, i re-enable it and guess what ? not working at. I debugged everywhere until i found this topic http://community.stencyl.com/index.php/topic,9508.msg59019.html#msg59019.

What is going on here ? In flash, works fine.. but on IOS, dude... what a nightmare.

See the attachments bellow.

TimeWave Games co-founder (http://www.timewavegames.com)

Released games: Silent Joe, ToughZone, 15Castaway
In Development: Probe Launched

mbenin

  • Posts: 13
Please guys ! stencyl crew ?
TimeWave Games co-founder (http://www.timewavegames.com)

Released games: Silent Joe, ToughZone, 15Castaway
In Development: Probe Launched

toml2003

  • Posts: 351
Hi, I saw you posted in my thread on this issue.

This isn't a fix, but is a workaround thats I've ended up using.

In the behavior you need to disable/enable, put all the code in one single boolean.

I've called my boolean "Disable".

I then make a couple custom events in these behaviors that say,

When 'disable' happens
[set Disable to True]

and the other,

When 'enable' happens
[set Disable to False]

You have to trigger the enable/disable events from your other behaviors.

mbenin

  • Posts: 13
yep!
i just did that yesterday =/

thanks anyway :D
TimeWave Games co-founder (http://www.timewavegames.com)

Released games: Silent Joe, ToughZone, 15Castaway
In Development: Probe Launched