Incompatible Sound File

Destroyy

  • Posts: 11
I've been working on my game like usual and when I tried saving the Swf. to my folder, I got this error.
" title="Hosted by imgur.com
I've tried deleting my music, and even turning off that behavior. But no luck. If you need my logs, here they are.

Max Finch

  • *
  • Posts: 2187
Hey there I get this message to when I don't export as a MP3 from audicity. Download audicity and the LAMEMP3 encoder and export your sounds as MP3's from audicity. Problem Fixed :)

Destroyy

  • Posts: 11
I actually just decided to choose another song to play with the game, this time the song file is an MP3 file. But I still get the same error message. :/

Thanks anyway for your help Max Glockling Games.

Bump, still need help!

Joe

  • *
  • Posts: 2480
Still looks like a sound problem:

[LOG] unable to resolve '../game/resources/524.mp3' for transcoding
[LOG] Unable to transcode ../game/resources/524.mp3.


Make sure your songs have a sampling rate of 44.1kHz and a 16-bit resolution, not just that they're MP3s.

Max Finch

  • *
  • Posts: 2187
Oh yea that to :) But usually it doesn't all anything higher then 16-bit and 44.1kHz??? Correct me if I'm wrong...

Destroyy

  • Posts: 11
I just decided to remove the background music, I even de-activated the behavior.
I took off any music I added.
But I'm STILL getting the same error message.

Here are the new logs as of right now.

FIX EDIT: I found the problem. I guess I had a file of music hidden somewhere with no imported music in the file. I guess the game didn't like that. I removed the file and it works perfectly now. Thanks for the reply guys.


« Last Edit: June 24, 2012, 06:09:01 pm by Destroyy »

Max Finch

  • *
  • Posts: 2187
[ERR] Warning: This kind of block does not exist: ACTOR

You should probably try and find this fake actor it might be screwing up your game.


EfrenStudios

  • Posts: 283
FIX EDIT: I found the problem. I guess I had a file of music hidden somewhere with no imported music in the file. I guess the game didn't like that. I removed the file and it works perfectly now. Thanks for the reply guys.

Where did you had hidden this music file?

I have the same problem but I don't have any music file hidden on the resource folder.
Everything is good if have pixel art on it...


Justin

  • *
  • Posts: 4570
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)