Strange Tilemap Problem

BenSironko

  • Posts: 9
This is an odd problem so I'll do my best to explain it in such a way that it makes sense.

I'm trying to make a level in which the bottom of the window is a floor made of tiles. The size of tiles for my map is technically 16x16 but I always place the tiles in blocks of 80x32. This is because I need a block size of 80x32 but I also need to be able to manipulate smaller tiles on the same grid.

The problem arises when I go to test the map. Instead of appearing at the bottom the tiles appear in the very top rows in the grid. The collision is located in the correct place but the image is completely wrong. It becomes a bit weirder when I save it and come back later. When this happens the tilemap in the editor has changed to match the glitch that occurs in the running game. So what I mean by this is that I leave the editor such that the bottom rows are filled with tiles and when I come back to the editor after closing Stencyl the top rows are the ones filled in. And once that happens the collision is even off when running the level.

Am I doing something wrong or can someone tell me what code I'll need to do a fix?

Alexin

  • *
  • Posts: 3130
Can you post some screenshots, please?
"Find the fun"
alexin@stencyl.com

Hectate

  • *
  • Posts: 4645
If you're going to have tiles that are 80x32, you'll still have to break them up into individual 16x16 tiles if you want to use the properly on a scene with a 16x16 grid.

You can still select a group of tiles to place at once by dragging the mouse to create a rectangle (when selecting tiles) of all the tiles you want to place.

You will get weird visual errors when placing tiles that don't match the grid size of the scene. I suspect this is the case...
:
:
Patience is a Virtue,
But Haste is my Life.
Proud member of the League of Idiotic Stencylers; doing things in Stencyl that probably shouldn't be done.

BenSironko

  • Posts: 9
Here are pictures of the editor and the runtime that the editor level produces. When I say that the editor level changes when I close Stencyl I mean that when I come back to the editor version of the level at a later time it looks exactly like the runtime level but the collision no longer exists at the bottom.

And I've made the tileset so that it consists of 16x16 tiles and then I select 5 tiles across and 2 down in order to make the block. As far as I know the editor shouldn't be able to tell the difference.

BenSironko

  • Posts: 9
Yeah I've been trying a lot more to just place the 16x16 tiles and it doesn't fix anything!

Rob

  • *
  • Posts: 1268
Can you also upload your game to Forge and also perhaps turn on collision debugger to see what's wrong?
GOLDEN RULE #1 : SAVE YOUR GAMES FREQUENTLY
IOS/XCODE DEBUGGING
http://www.stencyl.com/help/view/xcode-ios-troubleshoot/
WATCH STENCYLWORKS VIDEO TUTORIAL BY SUNRISEKINGDOM
http://www.youtube.com/watch?v=KDfRfjzr9j4&feature=channel_video_title

BenSironko

  • Posts: 9
I just figured out that when I reduce my level size it works. I normally set the level to 20000 pixels wide to give me room to build and then reduce it to the real size later. When it's set at 20000 it glitches and when it's set to 1024 it doesn't. What's the max size (in pixels) I can do?