Simple Melee attack

Storbusaren

  • Posts: 108
The behavior works fine which is awesome. Only problem is the animation. The player actor animation just glitches for a sec. It doesn't play the actual animation, just makes the actor disappear for a second.

Weird, it doesnt happen to me. Check one more time if you have chosen the right a animation from the "behavior menu".

Onenoodle

  • Posts: 84
Its definitely the right one. Just doesn't play properly. Do I have to put a "play" block in the code?

For normal animation, do I just put the idles?

Storbusaren

  • Posts: 108
Yes, the idles should be in the "Normal left/right animations".

Onenoodle

  • Posts: 84
I wonder, if I left the actor attack animations blank, and put the attack animations in the weapons animation slot. Would this work maybe?

Onenoodle

  • Posts: 84
Weird, its only picking up a few of my actors for weapons. Even though I put inflect damage on other things...

I thought it may have been the animation manager, do i just put Sidescroller sword attack at the top?

Storbusaren

  • Posts: 108
Yes, you should just put the Sidescroller sword attack in the player actor. (that swings with the sword). And if you would do like you said: "I wonder, if I left the actor attack animations blank, and put the attack animations in the weapons animation slot. Would this work maybe?". Then it may work, but the rest of your player's body will inflict dmg too. Like your head.

Onenoodle

  • Posts: 84
Yeah I was thinking that as well, we just want the sword to do the damage. Hmm...I don't know why its not playing it. It looks like its trying to, but just cant seem to play. Like maybe something else is resetting it or making it disappear...
Do I call it Sidescroller sword attack in the animation manager?

Storbusaren

  • Posts: 108
Maybe your player actor and your sword actors are in the same collision groups! They should be in different groups, and should not collide with each other. My sword is in a group called "Weapons". Try that.

What do you mean with animation manager?

Onenoodle

  • Posts: 84
I got excited, I thought that may have been the problem!
They were in fact in the same collision groups. Can't believe I didn't realize that. But still didn't fix it :/

The animation manager is a behavior that orders your animations giving the highest one right to over right and play the most important animation if signaled to.

Would you be able to try testing yours with the animation manager on your actor? Possibly could be the problem.

I really do appreciate your help Storbusaren. :)

Onenoodle

  • Posts: 84
I noticed some "knock back" in the code. Do I need that behavior for it to work properly?

Onenoodle

  • Posts: 84
I actually just realised, if you download a behavior etc, from stencylforge, and you don't have all their attributes etc, they don't carry across with the behavior. This could be the problem. I may be missing some stuff.
*bump

Storbusaren

  • Posts: 108
Yes, you need the "On Ground" behavior and one more, don't remember the name though. But every behavior you need is written in the description of the behavior.

Onenoodle

  • Posts: 84
Do I need knock back?

Storbusaren

  • Posts: 108
The only behaviors you should need is the ones listed in the description.

Onenoodle

  • Posts: 84
Yeah I've got them. Been trying for awhile but no solution yet :(