Design Mode Bug?

computermaster

  • Posts: 3
I've been making a game, but when I finished part of the main menu and tested the "start" button and then a message popped up.
  It says:
TypeError: Error #1009: Cannot access a property or method of a null object reference.
   at stencyl.api.engine::GameState/createActor()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:938]
   at stencyl.api.engine::GameState/loadActors()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:779]
   at stencyl.api.engine::GameState/loadScene()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:547]
   at stencyl.api.engine::GameState/enterScene()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:447]
   at stencyl.api.engine::GameState/update()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:1464]
   at org.flixel::FlxGame/update()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/flixel/org/flixel/FlxGame.as:407]
 
The picture and the log should be somewhere down there. Help would be appreciated! 

« Last Edit: February 15, 2013, 04:53:56 pm by computermaster »

dtrungle

  • Posts: 1938
You are trying to create an Actor that has not been set properly. Check your code and make sure the order and/or values are set before you use them.

computermaster

  • Posts: 3
Everything's filled in. Thanks for trying though!  :)
Edit:  Whoops... :-[ I just edited my topic. By "coding" I meant design mode, if that's what is playing with your thoughts. Sorry!

« Last Edit: February 15, 2013, 04:53:36 pm by computermaster »