Stencyl 3.4.0 is now out. Get it now!

Stencyl 1.0.3 / 1.0.4

Jon

  • *
  • Posts: 17515
Overview

StencylWorks 1.0.3 is a larger maintenance release that fixes a slew of bugs and introduces 2 notable enhancements. 1.0.4 is a follow up release that fixes some bugs that were introduced in 1.0.3.

StencylWorks 1.1, a major upcoming update, will arrive within the next few weeks.


How to Update

StencylWorks will prompt you to update next time you launch. You must be a registered user to update your copy.

If it doesn't prompt for an update, or if you wish to update right now, you can check for updates from the File menu.

If you see "Missing", re-attempt an upgrade by visiting the Debug menu. If the problem persists, let us know.


What's New? (1.0.4)

- Get font height block was breaking behaviors and games
- Tiles were shifted down and right by a half dimension
- Actor collisions were off, particularly if the shapes were offset from the top left corner.
- Some behaviors wouldn't load at all for (see RPG Platformer Kit > Actor Behaviors > Save Point wasn't loading)
- Recycled actors, when respawned, continue colliding with stuff before they were recycled (for one frame)
- Improved full screen mode
- Changing the volume through the Flixel (on screen) controls would stop sound playback


What's New? (1.0.3)

Pivot Points for Actors

As requested by many, we've added the ability to set the Pivot Point for an actor. This alters how an actors rotates and scales. By default, it's set to its center. You can choose from presets, or you can specify a custom value.




Block Simplification

Many of our blocks come in pairs. Enable/Disable. X and Y. It's quite common to want to switch between similar blocks. Moreover, we felt that in some cases, there were just too many separate blocks that could be clearer if they were combined together.

Hence, we swept over the entire repertoire of blocks and combined a bunch of them. Pictured here is the new Input category, which was simplified down from 3 separate pages of blocks to just 1.



Your games will automatically use the combined-forms of these blocks. As always, there may be errors, and we'd appreciate if they were brought to our attention if you think they're related to the block simplification.


What Else Has Changed? (Bug Fixes, Enhancements)

- Better indenting of outputted code
- Add functions to get Regions and Terrain
- Enter/Exit Full Screen Block
- Add GET/POST option to visit URL block
- Tag Flash/Flixel specific blocks with the Flash logo
- ProxyPage is causing troubles
- Script.getActorsInArea is faulty
- Duplicated actor not showing in palette until save/reopen.
- DM opening got slower
- Sound Channes don't work
- Sound Editor Dropdown is tall on Windows

Enjoy!

« Last Edit: March 13, 2012, 09:55:33 am by Jon »

SWATLLAMA

  • Posts: 1059
Great to hear that 1.03 is out, and even better that 1.1 is coming soon. However, this does raise a few questions.
For games that were/being made in 1.02 or earlier versions, does this mean that the games will no longer work? At the point I am at in my games, I'm alright with it corrupting my game files, but others may be farther with their games.
Hail The Llama
http://www.kongregate.com/accounts/lSWATLLAMA
"Play the games" ~ The Grand Llama

It's my life goal to rickroll as many people as possible

Jon

  • *
  • Posts: 17515
No games should break.

Sunflower

  • Posts: 591
Alright, this is really noticeable difference, and while I don't need to use Pivot Points right now, I must say it is quite important. Also, blocks simplification is a nice thing, too, though there's one change I'd like. I mean, I don't know how technically difficult it would be, but could you make it so that when you choose an option from menu its width in design mode is set to the width of this text, rather than maximum width of possibly chosen option? O.o I mean, I use X and Y coordinates quite often, and now places where I've used it are terribly wide. ^^'
(oh, in fact in actors choice menu there's no problem with that; Self is about as wide as Self and Last Created Actor is about as wide as Last Created Actor O.o)

Also, this POST thingy sounds nice to me. I just wonder... when you need to get the POST value, you use "response from website" and find it in this response? O.o

Last thing: part of "cat" starting from "1" ending at "2" still shows "a" instead of "at", and I don't see any changes in Help Center (in fact, HC is quite old, there are still informations about Game > Scoring blocks O.o).

Darkhog

  • Posts: 1243
Origin point is a center of mass, right?

If so I'd like to have second pivot which position would be return by get actor x/y instead of position of top-left pixel. Also for pivot points it'd be good to have drag'n'drop solution instead of entering values manually (maybe in 1.1 though)

There are no impossible things. There is only lack of skills.
Don't click this if your computer has less than 641 kilobytes of RAM.
Stencyl stencyling stencylish stencylers :D

Weasel8778

  • Posts: 236
Is it possible to change back to 1.0.2 from 1.0.3? I don't have a back-up and 1.0.3 changed my behaviours to the new blocks etc so I'm not sure it'll downgrade? :( :( :( :( :(

I'm sure 1.0.3 is an improvement but I've found loads of bugs in my game after the update and should have known better than to update mid-way through development...

EDIT:

No games should break.

This isn't true. Many parts of my game are working differently, and I only played through the first few levels - there could be more bugs that I haven't spotted... Some examples: my switching scene behaviour stopped working properly after the update, I can no longer push actors up a ramp (it just refuses to move after reaching the base of the ramp), I have a series of tiles with one of the tiles replaced as an actor (with identical appearance and collision boundaries) but if I try to walk right from a tile to the actor, my player somehow collides with something and won't move forward so I have to jump over it...

EDIT: Okay - I redownloaded Stencylworks 1.0.0 and unsurprisingly the downgrade from the new blocks to the old blocks wasn't perfect. The controls don't seem to work properly (eg the difference between 'is pressed' and 'is released' etc etc). Also, most of the 'play sound' blocks are missing, but not all of them, strangely... All the bugs I mentioned above were fixed, so 1.0.3 is definitely the cause of those problems.

Since I don't have a back-up, I guess the only thing I can do now is find out where I can get the 1.0.2 upgrade then just work out which blocks weren't downgraded properly and attempt to get the game back to how it was.

EDIT: I redownloaded 1.0.3 and oddly, all of the sounds and controls were fixed (???). So I have a scenario where I can reinstall 1.0.0 and see that there is absolutely no 'play sound' block in the behaviour, just to upgrade to 1.0.3 and have the sound block magically reappear (although obviously the 1.0.3 specific bugs appear too). Weird. Anyway, that gives me hope that upgrading from 1.0.0 to 1.0.2 will also sort the problem and I'll be back to where I was.

Any chance of a download link for 1.0.2?

EDIT: This is the main thread for my problem:

http://community.stencyl.com/index.php/topic,2179.msg15114.html#msg15114

« Last Edit: July 21, 2011, 08:09:54 am by Weasel8778 »

SWATLLAMA

  • Posts: 1059
Weasel, you make me frightened about upgrading to 1.03 o_O.
Hail The Llama
http://www.kongregate.com/accounts/lSWATLLAMA
"Play the games" ~ The Grand Llama

It's my life goal to rickroll as many people as possible

gmx0

  • Posts: 9
After I updated, all my games broke. Do I have to redownload?

Some blocks were labeled "Missing". I looked in the original post and most of the blocks that were missing are a result of the simplification.

Legendary Hoamaru

  • *
  • Posts: 1088
Weasel, you make me frightened about upgrading to 1.03 o_O.

His problems will be fixed in tonight's patch.

Jon

  • *
  • Posts: 17515
After I updated, all my games broke. Do I have to redownload?

Some blocks were labeled "Missing". I looked in the original post and most of the blocks that were missing are a result of the simplification.

If you are seeing missing, your language packs did not update for whatever reason, but this is part of the normal update process. You may want to use the reupgrade feature under the Debug menu to give it another shot.

If the language packs still don't update, file a bug and post your logs. It's a critical part of the update process that can't go incomplete.

Jon

  • *
  • Posts: 17515
We've temporarily taken the update offline and will release 1.0.4 tomorrow to resolve some of the issues raised. Those still on 1.0.2 and earlier will be able to upgrade directly to 1.0.4 (the system is built to handle cases like that).

We'd release it tonight, but we're still working on one of the issues as we speak.

Edit: Said issue is fixed. We're on schedule to put the new release out tomorrow morning evening (pending another issue resolution).

« Last Edit: July 22, 2011, 09:06:23 am by Jon »

EatMoreHippo

  • Posts: 62
The simplified blocks are really cool and useful for making numerous similar attribute setting behaviors (movement behaviors come to mind) and are much more malleable.

So thanks a ton for them; they were an addition I wanted to see added.

One other addition they make me think of though is a more fluid way of setting negate blocks for attributes, like if I could stick a - in there to suggest negate that would be useful.

Weasel8778

  • Posts: 236
I have a question:

I currently use 1.0.3 with the 1.0.2 engine because of a problem I had. However I'm at a different house for the weekend and carried my game across and of course the new blocks aren't recognised as it still has 1.0.2 (would have carried the whole Stencyl folder across but didn't realise that the 1.0.3 update was taken down).

If I download 1.0.4 when it's released then stick the 1.0.2 engine in there, will I be able to import my game, have it work fine, make changes and then be compatible with my 1.0.3 (with 1.0.2 engine) at home? I'm just wondering if I should wait it out or if it'll be compatible (I'll back up the game just in case anyway).

Aber

  • Posts: 33
I cannot speak for the team because I am relatively new here.

Since Stencyl is a new tool and I want to stabilize my work environment and my game, I would go to my work folder and make a copy of stencylworks to say, stencylworks 1.0.1 (while I was still using 1.0.1), then to stencylworks 1.0.2 (while I was in 1.0.2) etc. With this, I ended up having multiple stencylwork folders each with their own version (I am not upgrading any of them). If you prefer to try a game made with 1.0.1 in 1.0.3,  then you can copy to 1.0.3 and try to see if it works.

 This of course is all in hindsight.

Jon

  • *
  • Posts: 17515
I have a question:

I currently use 1.0.3 with the 1.0.2 engine because of a problem I had. However I'm at a different house for the weekend and carried my game across and of course the new blocks aren't recognised as it still has 1.0.2 (would have carried the whole Stencyl folder across but didn't realise that the 1.0.3 update was taken down).

If I download 1.0.4 when it's released then stick the 1.0.2 engine in there, will I be able to import my game, have it work fine, make changes and then be compatible with my 1.0.3 (with 1.0.2 engine) at home? I'm just wondering if I should wait it out or if it'll be compatible (I'll back up the game just in case anyway).

1.0.4 will work just fine with 1.0.3. You can continue to use the 1.0.2 engine with it, but we'd like some confirmation from your end that the 1.0.4 engine resolves the issues you saw in 1.0.3.

If you'd like to test right now, the patch topic already has the exact binaries I intend to release as 1.0.4 tonight.