Stencyl 3.4.0 is now out. Get it now!

Stencyl 1.0.3 / 1.0.4

SWATLLAMA

  • Posts: 1059
Jonny, what time zone are you in? It's almost 11 here, and it's not out yet. D: What counts as *tonight*?
Hail The Llama
http://www.kongregate.com/accounts/lSWATLLAMA
"Play the games" ~ The Grand Llama

It's my life goal to rickroll as many people as possible

Jon

  • *
  • Posts: 17515
Pacific. We're erring on the cautious side and are double-checking everything to avoid a reprise of last time.

SWATLLAMA

  • Posts: 1059
Okay, that's fair enough. Though now it's Saturday D:, but I'd rather have a late but great version than a buggy and early/ontime version.
Hail The Llama
http://www.kongregate.com/accounts/lSWATLLAMA
"Play the games" ~ The Grand Llama

It's my life goal to rickroll as many people as possible

deatherr1

  • *
  • Posts: 61
I still got the bug where I cant update.

Jon

  • *
  • Posts: 17515
Please re-post your logs here. Do other online features like Forge work at all for you?

Jon

  • *
  • Posts: 17515
1.0.4 is now live. If you were unlucky enough to grab it before 11:00 PM (PST) or so, use the reupgrade feature to pick up the official binaries.

If anything is amiss, let us know as soon as possible.

« Last Edit: July 22, 2011, 11:07:17 pm by Jon »

deatherr1

  • *
  • Posts: 61
Yes all online features work http://www.multiupload.com/J6ZEF9BMPD  Also can you attach other stuff other than pictures to the fourm?

« Last Edit: July 23, 2011, 12:19:21 am by deatherr1 »

Jon

  • *
  • Posts: 17515
Yes, and if not, you can always wrap it in a ZIP.

Jon

  • *
  • Posts: 17515
I need two more bits of info from you.

1) Open prefs/boot.txt and find the build field. What is its value?

2) Could you run SW again and then close it after it tries to auto-update (no action needed). Go to your logs directory, open the newest log and look for something that looks like this:

<r>
<server status = '200' version = '1beta' time = '1299439687' />   <version required="false" build="402" name="1.0.2" month="06" day="30" year="11" />
   <version required="false" build="401" name="1.0.1" month="05" day="31" year="11" />
   <version required="false" build="400" name="1.0.0" month="05" day="18" year="11" />
   <version required="false" build="399" name="0.9.9" month="05" day="18" year="11" />
</r>
<r><updateRootUrl value="http://static.stencyl.com/sw/stencylworksBeta/402" /></r>

Copy and paste that part into your post. The reason I want to ask is because I did take down 1.0.3/1.0.4 for a little bit before 11 PM, and you could have just checked at the wrong time.

deatherr1

  • *
  • Posts: 61
I think it is this <r>
<server status = '200' version = '1beta' time = '1299439687' />   <version required="false" build="404" name="1.0.4" month="07" day="23" year="11" />
   <version required="false" build="403" name="1.0.3" month="07" day="21" year="11" />
   <version required="false" build="402" name="1.0.2" month="06" day="30" year="11" />
   <version required="false" build="401" name="1.0.1" month="05" day="31" year="11" />
   <version required="false" build="400" name="1.0.0" month="05" day="18" year="11" />
   <version required="false" build="399" name="0.9.9" month="05" day="18" year="11" />
</r>
<r><updateRootUrl value="http://static.stencyl.com/sw/stencylworksBeta/404" /></r>
[LOG] http://static.stencyl.com/sw/stencylworksBeta/404/html/filelist
[LOG] HTTP/1.1 200 OK
[LOG] Attempting to quit out of StencylWorks.
[LOG] Performing final close.
[LOG] Exiting...
Also it shouldn't be a early 1.0.3 update bug because this bug happend before that then I reinstalled stenyl and got the bug again.
here is what my boot.txt says build=401
Edit that log might of been wrong one:
[LOG] Failed to load Growl library
[LOG] Loading: help\help\en\html\main\index
[LOG] Exists: false
[LOG] URL: index.html
[LOG] Dir:
[LOG] {}
[LOG] false
[LOG] MAXIMIZED FRAME
[LOG] Activated: Welcome Center
[LOG] Logged in as: deatherr1
[LOG] Usergroup: Beta Tester
[ERR] Attempting to log in
[LOG] Connected to StencylTalk as: (I just removed this because)
[LOG] Refreshing friends list
[LOG] 200
[LOG] http://www.stencyl.com/sw/updater/getVersions/stencylworksBeta
[LOG] HTTP/1.1 200 OK
<r>
<server status = '200' version = '1beta' time = '1299439687' />   <version required="false" build="404" name="1.0.4" month="07" day="23" year="11" />
   <version required="false" build="403" name="1.0.3" month="07" day="21" year="11" />
   <version required="false" build="402" name="1.0.2" month="06" day="30" year="11" />
   <version required="false" build="401" name="1.0.1" month="05" day="31" year="11" />
   <version required="false" build="400" name="1.0.0" month="05" day="18" year="11" />
   <version required="false" build="399" name="0.9.9" month="05" day="18" year="11" />
</r>
<r><updateRootUrl value="http://static.stencyl.com/sw/stencylworksBeta/404" /></r>
[LOG] http://static.stencyl.com/sw/stencylworksBeta/404/html/filelist
[LOG] HTTP/1.1 200 OK
[LOG] Attempting to quit out of StencylWorks.
[LOG] Performing final close.
[LOG] Exiting...

« Last Edit: July 23, 2011, 12:35:16 am by deatherr1 »

Jon

  • *
  • Posts: 17515
So what does SW say when you try to update? Error (in which case, what does it say?) or that you're already up to date?

deatherr1

  • *
  • Posts: 61
It downloads and says to restart and I restart it but it dosent install the update it acts like it was never downloaded

deatherr1

  • *
  • Posts: 61
Have you found anything that will fix it yet?

GregAnims

  • Posts: 299
Jon you are a goddamn genius, stencyl is going to be HUGE, especially with great updates like these. Thanks a lot for the new pivot point functionality!

Jon

  • *
  • Posts: 17515
Have you found anything that will fix it yet?

What directory are you running StencylWorks out of?