Chartboost Mobile Ads (Updated Apr 27)

rob1221

  • *
  • Posts: 9421
So something changed with Android recently?  Or did something change on your end?

manaskk

  • Posts: 153
when i first tried using chartboost it didnt work and i saw a newer version 10 , so i thought you guys made an update so that it works on android or something. so i updated to v10 but it still doesnt work. is it working on android or not ?? i couldnt get chartboost to work from the beginning

rob1221

  • *
  • Posts: 9421
It's probably working fine for most users, but we need to find out what's different about your situation.  Under Settings > Mobile > Versions, what do you have for the Android minimum and target versions?

manaskk

  • Posts: 153
@rob1221 , please check the attachment. i have the same issue for Vungle and unity :( . i purchased both of them from robin store but now its not working is it something to do with the android versions? looks like it's already at the lowest...

rob1221

  • *
  • Posts: 9421
http://stackoverflow.com/questions/36364047/i-got-missing-permission-issue-here-maps-android
I suspect it's related to that but you're already targeting below API 23 so I don't know what's going on.  I guess your device is on Android 6?

manaskk

  • Posts: 153
Yes my android version is 6, does that mean i cannot test on it ?

rob1221

  • *
  • Posts: 9421
I don't know.  I'm just trying to narrow down the problem.

colburt187

  • *
  • Posts: 2369
not sure if it helps but maybe its related to this thread in some way? http://community.stencyl.com/index.php/topic,49560.0.html

FMStudioGameDev

  • *
  • Posts: 206
@rob1221 , please check the attachment. i have the same issue for Vungle and unity :( . i purchased both of them from robin store but now its not working is it something to do with the android versions? looks like it's already at the lowest...

Just a guess: I know for sure that to make Unity work you have to target at least API 19.
http://community.stencyl.com/index.php/index.php?topic=47146.msg270528#msg270528
Maybe this can fix other issues...

manaskk

  • Posts: 153
not sure if it helps but maybe its related to this thread in some way? http://community.stencyl.com/index.php/topic,49560.0.html

@colburt thx for the link, so from the link they said downloading "android-ndk-r10e" fixes the problem with android 6?

manaskk

  • Posts: 153
@rob1221 , please check the attachment. i have the same issue for Vungle and unity :( . i purchased both of them from robin store but now its not working is it something to do with the android versions? looks like it's already at the lowest...

Just a guess: I know for sure that to make Unity work you have to target at least API 19.
http://community.stencyl.com/index.php/index.php?topic=47146.msg270528#msg270528
Maybe this can fix other issues...

@shimiegames , if downloading "android-ndk-r10e" doesnt fix the problem then i will give this a try..... will post a reply soon after trying both ways...

robinschaafsma

  • *
  • Posts: 711
@manaskk

As i can read in the Changelog of Chartboost versions it seems that you have to target API 23 before you can show ads on devices with Android 6. (Charboost Version 6.0.2 (Oct. 26, 2015))

https://answers.chartboost.com/hc/en-us/articles/207697966-Changelog-Android-SDK

You can set <android  target-sdk-version="23” /> to your project's Haxe flags in order to build for API 23.
Then you have to download android-ndk-r10e and  replaced just the "platforms" folder in android-ndk-r7b forder (temporary solution untill Stencyl support API 23 and NDK r10e) This will fix the crash on startup.

Hope this helps you a bit..

As ShimieGames has said, for Unityads you have to set target Version to 19 or higher.

luismp

  • Posts: 219
just wanted to say that after reading these "bugs" I've checked my android games and i can still see ads without problems (using galaxy s7 edge with latest android version available) and i haven't updated some of them in a year (so the chartboost version is 7 or 8 i think)... so i dont know if those crashes that manaskk mentioned  are somehow related to the way stencyl sends the game to the device..

xplosion28

  • *
  • Posts: 275
Any updates on chartboost using Xcode 8?

rob1221

  • *
  • Posts: 9421
Quote
Called from Date::date_format line 93
Uncaught exception - Segmentation fault
I haven't been working on it because I have no idea what to do about that error I got when trying to rebuild the extension.