Chartboost Mobile Ads (Not Updated)

rob1221

  • *
  • Posts: 9472
OK, what Stencyl build number?


rob1221

  • *
  • Posts: 9472
Update to the latest private build.  I'll make a note near the download link about that.

ertsgaming, same problem?

ertsgaming

  • Posts: 20
Hello agasin,

I'm using latest build...

rob1221

  • *
  • Posts: 9472
OK then please post full logs (Debug > Logs > Generate Logs)

Justin

  • *
  • Posts: 4530
I was debugging a user's game and I saw those errors too. I don't remember if it was before or after I updated to your latest release. I made some corrections though, and they went away sooner or later.

Code: [Select]
nme.JNI -> openfl.utils.JNI
And this one is pretty tough to catch, but there's an nme reference in one of the JNI strings. Should be:

Code: [Select]
startChartboostAndroid = JNI.createStaticMethod("com/rob1221/MyChartboost", "startChartboost", "(Ljava/lang/String;Ljava/lang/String;Lorg/haxe/lime/HaxeObject;)V", true);
Finally, in MyChartboost.java:

Code: [Select]
org.haxe.nme.* -> org.haxe.lime.*
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

bambucha

  • *
  • Posts: 46
Hello,

I think im experiencing the same error as ertsgaming.
Here are the errors when compiling (using build 8140) and using the latest version of the extension (feb 2nd i think):
Code: [Select]
[openfl.bat] C:\Users\Jakob\AppData\Roaming\Stencyl\stencylworks\engine-extensions/chartboost/MyChartboost.hx:12: characters 7-17 : Class not found : openfl.JNI
[openfl.bat] Source/scripts/SceneEvents_5.hx:71: lines 71-272 : Defined in this class
[openfl.bat] Source/scripts/SceneEvents_5.hx:121: characters 20-51 : Class<MyChartboost> has no field cacheRewardedVideo
Events for 'Menu':  Class<MyChartboost> has no field cacheRewardedVideo
from scripts.SceneEvents_5
line: 121
columns: 20-51
[openfl.bat] Source/scripts/SceneEvents_5.hx:178: characters 8-38 : Class<MyChartboost> has no field showRewardedVideo

the last 5 lines repeat for every extension block i used.

Any idea what could be wrong?
Check out my games:
Highway Dodger    Highway Dodger 2     Dev Blog (in the making)
           

rob1221

  • *
  • Posts: 9472
Thanks Justin.  I'll make those changes today.  I was so focused on 64-bit support that I forgot that the code changes apply to Android too and didn't bother to test.

EDIT: Version 5 is now updated and should work on Android now.

« Last Edit: February 04, 2015, 10:36:05 am by rob1221 »

bambucha

  • *
  • Posts: 46
EDIT: Version 5 is now updated and should work on Android now.

I can confirm that the extension works. But i have some weird graphical artifacts when i show a reward video (when the black screen with the "watch" button is sliding in and out).
Check out my games:
Highway Dodger    Highway Dodger 2     Dev Blog (in the making)
           

rob1221

  • *
  • Posts: 9472
When you say sliding in and out, do you mean Stencyl's slide transition or something else?  And can you post image or video?

bambucha

  • *
  • Posts: 46
Heres a pic: (Imgur link)

I get those jagged lines when the ad is sliding in and out. They disappear once its done sliding.
Check out my games:
Highway Dodger    Highway Dodger 2     Dev Blog (in the making)
           

rob1221

  • *
  • Posts: 9472
That's odd.  I'd guess it's either a device problem (try a different device), Chartboost problem, or OpenFL problem (try a pre-update Stencyl version).  I don't think the problem is my extension code because all I do is call the video and Chartboost takes it from there.

ertsgaming

  • Posts: 20
Hi thanks rob I will try this today and give you an update ^^

Thanks again.

Ok so i installed the new private build and your new extension and I still can't build my game not sure if it is up to chartmob but here is my log I'm sorry if it not related to your extension and I will post this log in another thread.

Thanks anyway.

Regards

« Last Edit: February 05, 2015, 02:14:06 am by ertsgaming »

rob1221

  • *
  • Posts: 9472
It's the Google Play Games extension causing that error.  Do a forum search for "String types not allowed".

ertsgaming

  • Posts: 20