Can't Test Scene or Game

Xnanga

  • Posts: 3
Hey everyone,

Me and my team are creating a 2D scroller with Stencyl for University coursework. We were doing fine until suddenly Test Scene or Test Game won't run the game. It commences loading but Flash doesn't open and the game doesn't play. We've tried removing certain features and actors that were added after we started having problems but to no avail.

We're noobs to Stencyl and can't work out what's wrong even with the log which I've uploaded here.

Can anyone help?

Thanks in advance for your help :)

Xnanga

  • Posts: 3
Oh and we've tried our project on both Mac and PC if that helps.

gamegirlxl

  • Posts: 716
You might have something wrong in your code that's stopping the compiler.  I think sometimes Stencyl fails to alert you to issues.

Try removing the sound, or the last thing you changed.

matthewd673

  • Posts: 18
I think that by simply restarting your computer, your problem will be fixed. This sort of thing happened to me a few times, just close it all out (after saving!) and open it back up again.

Additionally, if this happens again, you can also press the ~ key, and that will show you what Stencyl is doing in the background. If there is an issue with a scene or actor, it will usually tell you here.

Hope this helped! ;)
"Formula for success: rise early, work hard, strike oil." - J. Paul Getty

gamegirlxl

  • Posts: 716
I think that by simply restarting your computer, your problem will be fixed. This sort of thing happened to me a few times, just close it all out (after saving!) and open it back up again.

Additionally, if this happens again, you can also press the ~ key, and that will show you what Stencyl is doing in the background. If there is an issue with a scene or actor, it will usually tell you here.

Hope this helped! ;)

From what Xnanga said, they couldn't get a Flash window to open up on two different OS's.  That means that the console is useless and also reopening it didn't work.  Although you should restart your computers fairly often.

Xnanga

  • Posts: 3
Thanks for the replies everyone.

As gamegirlxl said, we've tried the project on different OS's and restarted so many times without any luck :/

We've also looked through our code for errors and we've tried removing recent additions to the project with no luck either.

One thing we have noticed is that sometimes one scene we try and test will work, and after finding one scene that works, the rest will work also. So we've found a temporary fix for now, hopefully we can figure out something more long-term.