changing path to haxe

Gintonic

  • Posts: 69
I've installed haxe 2.10 and after I've made some changes in an extension I try to compile the ios stuff by clicking on 'build' in the project folder I got errors.

How can I change the path from

/Users/Branko/Stencyl-full/plaf/haxe/lib/hxcpp/3,0,2/

to haxe 2.10 in

usr/lib/haxe?


haxelib path hxcpp
---------------------
/Users/Branko/Stencyl-full/plaf/haxe/lib/hxcpp/3,0,2/
-D hxcpp

haxe
-------------------
Haxe Compiler 2.10 - (c)2005-2012 Motion-Twin
 Usage : haxe -main <class> [-swf|-js|-neko|-php|-cpp|-cs|-java|-as3] <output> [options]
 Options :
  -cp <path> : add a directory to find source files
  -js <file> : compile code to JavaScript file
  -swf <file> : compile code to Flash SWF file
  -as3 <directory> : generate AS3 code into target directory
  -neko <file> : compile code to Neko Binary
  -php <directory> : generate PHP code into target directory
  -cpp <directory> : generate C++ code into target directory
  -cs <directory> : generate C# code into target directory
  -java <directory> : generate Java code into target directory
  -xml <file> : generate XML types description
  -main <class> : select startup class
  -lib <library[:version]> : use a haxelib library
  -D <var> : define a conditional compilation flag
  -v : turn on verbose mode
  -debug : add debug informations to the compiled code
  -help  Display this list of options
  --help  Display this list of options





Jon

  • *
  • Posts: 17523
Just a quick FYI - Stencyl is based on Haxe 3.0.1, so installing 2.10 is probably not the best idea for future compatibility purposes. Stencyl bundles the version of Haxe it will work with, so even if you were able to replace the bundled Haxe, you'd be out of luck since Stencyl assumes/outputs Haxe 3.0 compliant code.

Gintonic

  • Posts: 69
Ah, ok. I thought, I have to use haxe2 for compiling the extension stuff outside of stencyl:

"Using a text editor is a perfectly fine solution.
If you want to use use an IDE, you'll need to install Haxe 2.x (not 3.x), otherwise your computer won't be able to build from outside Stencyl's environment"

(http://www.stencyl.com/help/view/develop-engine/)


Jon

  • *
  • Posts: 17523
That was when we were based on NME and hasn't upgraded to OpenFL. I'll make sure the docs get updated again for 3.0.