Bigger enemies appearing instead of walking into playable area[SOLVED]

bwwd

  • Posts: 15
Hi, i have this problem with actors, i know its about their size, but i dont know where to change settings so they would walk in normally, the problem is that when i go forward then enemies walk to my direction but they dont appear immediately , they appear after half second when their position  is not offscreen anymore, you can test what i mean by playing the demo, i would like to solve that issue cause it basically prevents me from using my characters in the game, i tried to setup scene with tiles 64x64 but it didnt helped so im clueless now.I also enables physics in platforms cayuse theyre actors as well and they have the same problem too, they appear too late.
Here is the demo to test how it looks like:
http://www.fastswf.com/mqIIR30

« Last Edit: January 01, 2014, 03:47:25 pm by bwwd »

bwwd

  • Posts: 15
no solution? I cant use big characters because of this, they disappear too soon and appear too late when walking into playable area which is weird and shouldnt happen, i dont know how engine detects when to show or hide sprites, especially big ones.I need to know this to edit the values for bigger sprites.

Photon

  • Posts: 2697
Try attaching the "Always Simulate" behavior to them if you don't already have it on them.
Do NOT PM me your questions, because I likely will not respond. If I have replied to your question on the forum, keep using that topic. Thanks!

bwwd

  • Posts: 15
Thanks, you solved my problem, there is "always simulate but hide when offscreen" which should be enabled by default or at least should be available for every actor in default physics options to turn it off because actors are hidden too when offscreen now anyway but it happens too soon ( no clue why), this behaviour fixes this problem so now i can use bigger actors, thanks  :D