Android BUILD FAILED [Solved]

wdbank

  • *
  • Posts: 3
Hi, I'm new here and I just try to test game on android as http://www.stencyl.com/help/view/setup-android says but I got this

[LOG] BUILD FAILED
[LOG] Unexpected problem on thread AWT-EventQueue-0: null
[LOG] C:\Users\WDbank\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:598: The following error occurred while executing this line:
[LOG] C:\Users\WDbank\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:713: The following error occurred while executing this line:
[LOG] C:\Users\WDbank\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:727: Class not found: javac1.8

I'm try with sample game but still get same problem

Please help and Thanks in advance : )

« Last Edit: March 20, 2014, 11:12:20 am by Jon »

Jon

  • *
  • Posts: 17529
You need to install Java 1.6 (also loosely referred to as Java 6) - you appear to have the brand new Java 8, which won't be compatible with the Android SDK or Stencyl for that matter.

wdbank

  • *
  • Posts: 3
It's working! Thank you Jon. Just see that it say 'Java Development Kit 6 (JDK). Version 7 is NOT ok.'  My bad ; P

Phili9000

  • Posts: 1
Hello I have a similar error.

BUILD FAILED
[LOG] C:\Users\Philipp\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:598: The following error occurred while executing this line:
[LOG] C:\Users\Philipp\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:713: The following error occurred while executing this line:
[LOG] C:\Users\Philipp\AppData\Roaming\Stencyl\stencylworks\android-sdk\android-sdk-windows\tools\ant\build.xml:727: Class not found: javac1.8
[LOG] Total time: 5 seconds
[LOG] Finished building for Android (or errored out): 1

I installed
 jdk jdk1.6.0_21
jdk1.7.0_55
jdk1.8.0_05
and jre 6-8
but it still doesnt work.
I don´t the reason for my problem is same as wdbank´s reason because installing jdk 1.6 didn´t help me.

I am still very very new to Stencyl and I really don´t know what I could do.

I hope you know what I did wrong.

Thank you!

Jon

  • *
  • Posts: 17529
You cannot have multiple versions of Java installed because it'll use the latest one. Uninstall all the others.

aryan123

  • Posts: 1
Thanks a lot , i deleted my jdk 8 and installed jdk 6
and now it works   :D :D :D :D

DCameron

  • Posts: 63
Is jdk 6 still the version to be using?
Artist for hire: http://community.stencyl.com/index.php/topic,49739.0.html

Play my games on Kongregate:                                     Get updates on my Patreon page: