*Sorta Fixed, waiting for it to break again :P * Problem with looping sounds

SpookyBurger

  • Posts: 82
Hi!  I'm having a issue where a looping sound (a explore theme that's 2:30 long) ends the loop not at the end of the song.

Right now how I have it set up is

Start at title screen
   go to new game
   loop explore theme on channel 1
   take player to first stage


No other scene or behavior interacts with channel 1.  The reason I'm trying to get the track to loop is cause the individual scenes are short, so I want the track to keep playing as you change scenes.   I've also tested the track in Stencyl and it's the appropriate length in Stencyl and Audacity.

Thanks in advanced for any help :)

« Last Edit: May 30, 2014, 10:43:44 am by SpookyBurger »
Please try out my latest build of Patient 9 here.   http://www.stencyl.com/game/play/23179

sdieters

  • Posts: 2068
im not sure how i have to imagine your behaviour.
can you show me a screenshot?
My new profile is TheIndieStation.
When you see a recent post with this name, i'm probably using my phone. So dont mind any typo's =p

SpookyBurger

  • Posts: 82
Here's the screenshot.  The audio jazz is near the bottom.
Please try out my latest build of Patient 9 here.   http://www.stencyl.com/game/play/23179

sdieters

  • Posts: 2068
wow....
have you ever created a game before?
no offence, but this code is so unorganised that it wouldn't suprise me if the game itself looses track of what should happen.

i cant see anything that might cause this to happen, but i really recomment you to simplefy your code. if you are intrested, i am willing to help you out to give a bit more understanding of how to build a more organised code which will run smoothly.
My new profile is TheIndieStation.
When you see a recent post with this name, i'm probably using my phone. So dont mind any typo's =p

SpookyBurger

  • Posts: 82
Sorta fixed atm

I re exported the MP3 under a different name,  imported it into stencyl as a new sfx, and had the title screen handler play that instead.  so far it seems to be working properly.

@sdiesters:  right now it works, so im not really interested in cleaning up anything or learning new practices till I get this game done.  afterwards im willing to take you up on your offer.  thanks :)
Please try out my latest build of Patient 9 here.   http://www.stencyl.com/game/play/23179

sdieters

  • Posts: 2068
Quote
@sdiesters:  right now it works, so im not really interested in cleaning up anything or learning new practices till I get this game done.  afterwards im willing to take you up on your offer.  thanks :)

im not telling you to redo the whole game, but the way you build your code might be the problem itself. it is asking WAY to much from your cpu then it should
My new profile is TheIndieStation.
When you see a recent post with this name, i'm probably using my phone. So dont mind any typo's =p