Installing Stencyl on Ubuntu


  • Posts: 8
Good night peoples.

So i got ubuntu myself and asking how to install stencyl 3.1 on my OS "ubuntu 14.04 LTS"

im very very very new to ubuntu, i did what your website said about how to install it... but i still have no idea....
can you guys explain what to do step by step? thanks alot.

(i started working with stencyl in ubuntu because the android testing wont go right on windows... i did everything but nothing worked.. so im doing it with ubuntu now...)

greets newpro


  • Posts: 91
Welcome to Ubuntu Linux and Stencyl.
I am not sure about 14.04 (I guess it should work), but my 12.04 LTS 64-bit works great and I have no problems testing my games on android devices whatsoever.

To get help, I am afraid you have to be more specific to describe what is wrong and what you have already done.
Start your Stencyl adventure from,12.0.html especially 'Be specific' part.
Are you sure you did everything from that link?
Maybe also check this
It shows the process of installing previous version of Stencyl on Ubuntu 12.10, so it might provide some visual aid if you are not really sure what your are doing in Ubuntu.
I will watch this post and will try to help you later if you still have problems.


  • Posts: 8
Thanks for your reply.
About the "be specific" part: there are no more details.. you already answered me the "full guide" and that was what i wanted.

I entered in the Terminal:
(I have a 64-bit one, so i  skipped step 1)
Step 2: 
sudo apt-get install libxtst6:i386 libXext6:i386 libxi6:i386 libncurses5:i386 libxt6:i386 libxpm4:i386 libxmu6:i386 libxp6:i386


Step 3:
 sudo apt-get install libgtk2.0-0:i386 libxt6:i386 libxext6:i386 libatk1.0-0:i386 libc6:i386 libcairo2:i386 libexpat1:i386 libfontconfig1:i386 libfreetype6:i386 libglib2.0-0:i386 libice6:i386 libpango1.0-0:i386 libpng12-0:i386 libsm6:i386 libx11-6:i386 libxau6:i386 libxcursor1:i386 libxdmcp6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 zlib1g:i386 libnss3-1d:i386 libnspr4-0d:i386 libcurl3:i386 libasound2:i386
and to the video at minute 2:40:
sudo add-apt-repository ppa:upubuntu-games

there appears:
Cannot add PPA: 'ppa:upubuntu-games'.
Please check that the PPA name or format is correct.

maybe its because it shows stencyl 2.xx and not 3.1



  • Posts: 91
You were not suppose to follow the steps in the movie per se, because it explains installation of old version of Stencyl on different, older version of Ubuntu. 
It was just in case you totally have no idea what to do in Ubuntu, what to open where and how - visual aid how to handle Ubuntu OS. Also maybe to give you some clues.

The real guide is
If you did everything from there, it probably should work.

OK, but lets try to get more info from you.
When you try to run the Stencyl from the terminal (you should always try to do that when having problems  running something on Linux), then what happens next? What are the messages/information displayed ?

Anyway, I will probably try to install your version of Ubuntu this weekend and try to install Stencyl on it, making notes step by step, so you and other Ubuntu users will have a better guide for the future.


  • Posts: 8
thanks alot, i did everything, but one question:

"try to run stencyl"

how do you even run stencyl? double click on the shell-skript data named stencyl? i did it, but it opens with gedit and some text appears.
im spoiled with the confortable .exe from windows, so i have no idea what to do :D


  • Posts: 91
Before we try something else, try to right-click on the Stencyl file (the one you click and it opens in gedit).
When window pops-up, go to Permissions tab and check Execute: box to "Allow executing file as program"
Then click Close button.
Try to click the Stencyl again to start it. When question pops-up "Do you want to run Stencyl, or display its contents?
press Run button.

Let me know how it goes.


  • Posts: 8
the "Allow executing file as program" was already ticked

the box ticked or not ticked it still starts the same way.

i open it with the double click the left click button like always to open. i do right click and choose properties.
i event choose at "open with"  "run program" as "standart open way"


  • Posts: 91
I checked the forum and I see that you have the same problem the 13.10 users had:,29800.msg173536.html#msg173536

I think I have to investigate the thing on 14.10 LTE cause on my 12.04 it works differently and I don't see problems you see, so it is quite pointless to hunt things I can't catch. Like I mentioned before, I will try to install 14.10 LTE first, then make step by step instruction of what I need to run Stencyl on it, maybe even with screenshots ;)
Have patient. I will try to do that today. Starting to look for a spare HD to erase.


  • Posts: 8
hey dareek i very appreciate your effort, take your time, i'll wait.... (you mean 14.04 LTS instead of 14.10 LTE? )

little tip i you dont know:
you can make a partition with ubuntu, put the ubuntu.iso with unetbootin on your usb stick; boot it and make a partition+install with it. you can earase it later if you want


  • Posts: 91
OK, I may have found a solution faster than I expected:

  • open Ubuntu Software Center;
  • install 'OpenJDK Java 6 Runtime';
  • go to Stencyl folder;
  • open Stencyl file in gedit;
  • erase './runtimes/jre-linux/bin/' and leave only 'java';
  • save the file;
  • open terminal;
  • go, using command 'cd ./Stencyl-64-full/' to the Stencyl's folder (press enter after writing the so called path to the Stencyl's folder. In my case it was /Downloads/Stencyl-64-full cause I unpacked Stencyl in Downloads folder . In your case it will be probably something different, depends where you unpacked the Stencyl's folder;
  • run the Stencyl by writing './Stencyl' command and pressing Enter.
I attach the screenshot that shows what to install and what change to make in Stencyl file and how cd ./ command works in terminal.
You should be set.


  • Posts: 8
this error appears


  • Posts: 91
Strange. I took ubuntu 64 bit install iso, put it on a pendrive and boot from it into 'try ubuntu'. Then I installed java, made a change in Stencyl file and it runs fine on a pendrive.

I don't know man. Before I try to search for this java error, be sure that libc6 is installed on your system, as Stencyl's tutorial mentions.
Maybe run in terminal
apt-get install libc6-384 libc6-dev-i386
just to be sure.


  • Posts: 91
Also, what's the output of 'java --version' in terminal, check just to be sure it is a version 6.


  • Posts: 8
thanks bro, it worked...

i reinstalled ubuntu...
the problem occured because i messed arround with ubuntu trying fixing the problem by myself with several google submits

<3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3 <3


  • Posts: 8
last question: for android testing i have to locate my Java-JDK Folder... how to do it? where is it#?