Multi touch and jump button not working

lonesword

  • Posts: 3
For two days I have been fighting what is wrong with my jump button on android phone. I hope someone has the heart to put me out of my misery on this.

Long story short. I create a fresh game using the jump and run kit. I test it on my android right away and notice that the basic on screen arrows and A (jump key) dont work as multi touch. I can run, but I cant jump, or I can jump but not run. 
So I dump the virtual buttons and download the multi touch virtual button. same outcome.  Double check settings controls and multitouch is enabled.  Using yesterday and todays new build.

What am I doing wrong?

I've tried using the platformer movement resource as well, only in this case the buttons don't even show when compiled to android! I've checked physics,  anchor to screen, layers, controller settings and i am completely stumped why I can't run and jump.

Suggestions?

lonesword

  • Posts: 3
I just downloaded the stencyl sample platform game (the robot one) and compiled it to my droid maxx. Same issue. Jumping and running cannot be used at the same time.

Is this a bug with recent releases, java sdk, android? 

sdieters

  • Posts: 2068
this is no bug. The problem is that those behaviors are not meant to be used as multitouch. If you go to my channel, I have uploaded a video regarding Stencyl's multitouch system. If you watch those video's you will be able to solve this problem.
My new profile is TheIndieStation.
When you see a recent post with this name, i'm probably using my phone. So dont mind any typo's =p

TinSleeves

  • Posts: 6
this is no bug. The problem is that those behaviors are not meant to be used as multitouch. If you go to my channel, I have uploaded a video regarding Stencyl's multitouch system. If you watch those video's you will be able to solve this problem.

I'm also having this problem
Now checking out your videos sdieters, which video specifically addresses this problem?!
Thanks  :D

sdieters

  • Posts: 2068
My new profile is TheIndieStation.
When you see a recent post with this name, i'm probably using my phone. So dont mind any typo's =p

MikePL80

  • Posts: 45
Hi Sdieters

Firstly thank you for your videos, They are very helpful.
I have one problem after following your multi touch video part 2.

The touch sensors for my on screen buttons are about 100px below the actor I have attached the behaviour to even though I copied your set up exactly.

Do you have any idea why this might be happening?

Thanks
Mike

TheIndieStation

  • *
  • Posts: 2263
Hey Mike!
Can you show me your behavior?

MikePL80

  • Posts: 45
Hi TheIndieStation

Thank you for the quick reply but I managed to fix it.

It was a problem with my anchor to screen behavior.

Thanks again
Mike