Blurry GFX in Atlas [b42]

JensWinterstein

  • *
  • Posts: 433
I discovered a few blurry graphics in the main atlas. The atlas isn't oversized and the sourcefiles look fine in gimp/photoshop.

Here's a comparison:


Ideas? :)

« Last Edit: September 20, 2011, 11:07:08 pm by Jon »
Get 100 Chambers for Android / iOS
Get Cubus Velox for Android / iOS or play it on Flash

- Portfolio

Jon

  • *
  • Posts: 17529
Probably because they're scaled down for 1x using a non-nearest-neighbor algorithm. If you peek at the 2x, it will appear the way you expect.

I guess I can add an atlas setting to specify what downsizing algorithm you'd like used.

Jon

  • *
  • Posts: 17529
Saw this a ton in Manuel's game too - I'll address it for b42.

Jon

  • *
  • Posts: 17529
b42

The only catch for now is that it doesn't carry over to the Flash games yet. It only applies to the atlases.

To use this, head over to an atlas page and select Nearest Neighbor. That's all you have to do to maje it work.

JensWinterstein

  • *
  • Posts: 433
That was quick!  :o
Thanks for looking into the issue. :D

Edit: After downloading b42 and auto-updating to 1.1.1 again, I can't seem to find an atlas option called "Nearest Neighbor". Am I supposed to auto-update? Am I going insane?  :-X

Edit2: fixed (see answer below)

« Last Edit: September 21, 2011, 10:46:34 am by JensWinterstein »
Get 100 Chambers for Android / iOS
Get Cubus Velox for Android / iOS or play it on Flash

- Portfolio

Manuel

  • *
  • Posts: 764
Weird, did you look for it at the "Resize Method" dropdown that you find in the Atlases page?
Game developers are the deities of the virtual realm.
Game Development Blog
Personal Tumblr
Personal Twitter


JensWinterstein

  • *
  • Posts: 433
Thanks for pointing it out guys. Did you autoupdate to 1.1.1 after downloading b42?
Because this time I didn't and now I'm able to see the "Resize Method" dropdown menu.

Also, the blurry stuff is gone :)

Get 100 Chambers for Android / iOS
Get Cubus Velox for Android / iOS or play it on Flash

- Portfolio

Rhys

  • Posts: 1046
Try not to update to 1.1.1 when using iStencyl.

Jon

  • *
  • Posts: 17529
I'll make sure autoupdate is turned off for the next one. I thought I did but apparently forgot.