Problems upgrading to 3.2 Build 8085 (urgent)

messoft

  • Posts: 32
hello
I'm having problems to upgrade my project to 3.2 version

This is my game running in 3.1,everything works


This  appears when I updgrade to 3.2



Clic Ok and run the game
that error appears again and then ...


And Stencyl delete blocks in many places


and i run the game again and this appears




Pleasse Help!!!!!

My logs



captaincomic

  • *
  • Posts: 6108
Code: [Select]
2015-01-28 13:00:18,301 ERROR [Thread-34] stencyl.sw.util.StreamGobbler: [nme.bat] Source/scripts/SceneEvents_0.hx:86: characters 8-27 : Not enough arguments
2015-01-28 13:00:18,302 ERROR [Thread-34] stencyl.sw.io.write.resource.HXWriter: Events for 'Level 9':  Not enough arguments
from scripts.SceneEvents_0
line: 86
columns: 8-27
2015-01-28 13:00:18,302 ERROR [Thread-34] stencyl.sw.util.StreamGobbler: [nme.bat] Source/scripts/SceneEvents_0.hx:86: characters 8-27 : Function 'hideTileLayer' requires arguments : refType, ref
2015-01-28 13:00:18,302 ERROR [Thread-34] stencyl.sw.io.write.resource.HXWriter: Events for 'Level 9':  Function 'hideTileLayer' requires arguments : refType, ref
from scripts.SceneEvents_0
line: 86
columns: 8-27
Looks like you are using blocks from the Tile API extension. The extension is deprecated, and you need to replace those blocks with the new ones from the core palette (Scene -> World -> Tile API).

Use Run -> Clean Project from the menu afterwards.