Shaders not working

1MrPaul1

  • *
  • Posts: 1268
I tried to apply shader effect and it shows me just black screen, why?
I'm doing everything as was shown in stencylpedia, applying contrast shader.
Build 8059

letmethink

  • *
  • Posts: 2547
What OS are you building for?
~Letmethink

rob1221

  • *
  • Posts: 9419
Shaders don't work well (if at all) outside of desktop.

1MrPaul1

  • *
  • Posts: 1268
I tried it on desktop.

letmethink

  • *
  • Posts: 2547
I'm not too sure that osx works as I remember reading reports about people struggling it at some point. Are you using it? (I may be completely wrong and be thinking of something else, if I am tell me)
~Letmethink

1MrPaul1

  • *
  • Posts: 1268
I'm on windows 7 x64.
Tried all shaders, always just black screen...


rob1221

  • *
  • Posts: 9419
That's odd.  What graphics card?

1MrPaul1

  • *
  • Posts: 1268
yes, it is strange...

My video card is internal "Mobile Intel 4 series"

Jon

  • *
  • Posts: 17520
You should try out the latest builds. Reports are that the upgrades fixed up shaders for some people for which it was previously broken.

1MrPaul1

  • *
  • Posts: 1268
I saw red text with warnings that last builds can be not stable because of migrating to the new openfl version.
is it save to use new builds? I want to finish my gamein this month.

captaincomic

  • *
  • Posts: 6109
Yes, the upgrade issues have been resolved. The latest build should be working fine now.

sandeepraj

  • Posts: 2
i'm using latest version and still shaders are not working
i am working mac mini