Broken game


  • Posts: 9
I was building my game and i decided to test it on android. So i clicked test game and it saved, finalized, compiled and sent to device, but it produced the message "unfortunately, my game has stopped". I then tried on flash player, and it produced an error code. I deleted the game, and then put one of my backups in. I tried again with flash player, and it produced this error:

TypeError: Error #1009: Cannot access a property or method of a null object reference.
   at com.stencyl.models::GameModel()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/models/GameModel.hx:136]
   at com.stencyl.models::GameModel$/get()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/models/GameModel.hx:46]
   at[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/models/actor/Animation.hx:74]
   at[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/io/SpriteReader.hx:113]
   at[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/io/SpriteReader.hx:53]
   at com.stencyl::Data/readResource()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Data.hx:265]
   at com.stencyl::Data/readResourceXML()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Data.hx:251]
   at com.stencyl::Data/loadResources()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Data.hx:206]
   at com.stencyl::Data/loadAll()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Data.hx:140]
   at com.stencyl::Data$/get()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Data.hx:47]
   at com.stencyl::Engine/begin()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:652]
   at com.stencyl::Engine()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:511]
   at Universal/init()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/Universal.hx:57]
   at Universal/onAdded()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/Universal.hx:36]
   at flash.display::DisplayObjectContainer/addChild()
   at Universal$/main()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib/stencyl/1,00/Universal.hx:694]
   at Function/
   at Function/<anonymous>()
   at Reflect$/callMethod()[C:\Program Files (x86)\Stencyl\plaf\haxe/std/flash/_std/Reflect.hx:56]
   at ApplicationMain$/begin()[Export/flash/haxe/ApplicationMain.hx:56]
   at ApplicationMain$/preloader_onComplete()[Export/flash/haxe/ApplicationMain.hx:83]
   at scripts::StencylPreloader/onLoaded()[Source/scripts/StencylPreloader.hx:316]
   at ApplicationMain$/onEnter()[Export/flash/haxe/ApplicationMain.hx:75]

i have also ran in debug mode and still doesnt work. i have tried a sample game and it worked.

Flash browser displays nothing.

Last time this happened (with the same game!) i deleted favourites.xml   ,  game.xml     and     game.xml.bak and then went into stencyl, created a new game, and copied the new game favourites.xml    ,     game.xml     and    game.xml.bak into the game that stopped working and it worked again. This time i tried that and it didnt work, so i deleted it and tried to use a backup but didnt work! I have attached all the backups below. I am running windows 7 64-bit.  Also, my logs are attached below. My workspace folder is c:/users/patel/appdata/roaming/stencyl/     .     I have attached most of the stencylworks folder as well ( except logs, because the ones just before and after problem are posted, if i posted them all it exceeds the max attachment size, except games because the backups are already posted, except games-generated, android-sdk and tools as it exceeds max attachment size).
Had to post attachments seperate because of max attachment size.


  • Posts: 9
backups for stencyl


  • Posts: 9
half of stencylworks folder


  • *
  • Posts: 6108
When I open one of your backups as they are (with the name followed by spaces and a number), I get many errors.

If I remove the spaces and number at the end, I can open and run the backups without errors...


  • Posts: 9
so i put latest backup in, and restarted laptop, it works now but if i edit something it stops working

Squirrel Lord

  • Posts: 25
"TypeError: Error #1009: Cannot access a property or method of a null object reference."

You have an attribute with no value somewhere, I think.
Check through all of your behaviors, and make sure all attributes have an assigned value.

You may also have a reference to a control that has not been created in your backup game....