blank screen

readerboy7

  • Posts: 59
i made a game and finished it but it has one problem: when i tried to upload it on stencyl or test it using flash it displays a blank screen. you can see it here http://www.stencyl.com/game/play/8253 or play it on stencylforge called idle.

Alexin

  • *
  • Posts: 3132
If it's going to be an idle game, you can just leave it as it is. It just displays a black screen and eats up RAM (I stopped it at 1.5GB!).

There's probably an infinite loop when the game starts and it basically "freezes" it.
Behaviors, please.
"Find the fun"
alexin@stencyl.com

readerboy7

  • Posts: 59
i made a game and finished it but it has one problem: when i tried to upload it on stencyl or test it using flash it displays a blank screen. you can see it here http://www.stencyl.com/game/play/8253 or play it on stencylforge called idle.

« Last Edit: October 13, 2011, 09:18:51 pm by readerboy7 »

Alexin

  • *
  • Posts: 3132
I can test the game on the browser and Flash player. However, it shows a black screen when exported, both to the site and as a SWF (displays in the Flash player too).

I can't see anything wrong in the logs.
"Find the fun"
alexin@stencyl.com

readerboy7

  • Posts: 59
it also fails on kongregate (i was trying to upload it and i am lucky it has a cancel upload)
i used firefox.
how can it be fixed

readerboy7

  • Posts: 59
just bumping.
HOW CAN IT BE FIXED!

coleislazy

  • *
  • Posts: 2607
It is your sound. If I remove the block that loops the sound, it works for me.

readerboy7

  • Posts: 59
i removed the sound. the game started loading but once it finished, it displayed a black screen.
PLEASE HELP!!!!!!!!!!!!!!!!!!!!!!!!

readerboy7

  • Posts: 59
here's a crazy idea: WHAT IF SOMEONE ACTUALLY HELPED ME!
(before the bit in capitals was also in size 36. ithis may be the reason for the comment below.

« Last Edit: October 16, 2011, 10:16:09 pm by readerboy7 »

coleislazy

  • *
  • Posts: 2607
We've been trying to help you. I'm sorry our suggestions didn't work, but this is not the way to act. We are all volunteers and most of us have very busy lives, so it is not easy for us to check out problems like this.

readerboy7

  • Posts: 59
sorry. but i would enjoy help.

Hectate

  • *
  • Posts: 4643
We don't have enough information to just tell you what is wrong, so we are troubleshooting - a process that takes time as specific possible problems are eliminated as being possible to hopefully have us end up with one problem that is the likely cause. Once we locate that specific problem we can then determine how to fix it.

There is no magic bullet to fix a game problem. Game development is work - even if it is work that some people like to do as a hobby it is still work.

So, describe to us how the idle game is supposed to work and what it is intended to do, and what steps you have taken to get to that point.
:
:
Patience is a Virtue,
But Haste is my Life.
Proud member of the League of Idiotic Stencylers; doing things in Stencyl that probably shouldn't be done.

readerboy7

  • Posts: 59
do these seem strange:

TypeError: Error #1034: Type Coercion failed: cannot convert stencyl.api.engine::GameState@5abb0a1 to stencyl.api.engine.actor.Actor.
   at stencyl.api.engine.behavior::Behavior/initScript()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/behavior/Behavior.as:109]
   at stencyl.api.engine.behavior::BehaviorManager/initScripts()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/behavior/BehaviorManager.as:109]
   at stencyl.api.engine::GameState$/initBehaviors()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:621]
   at stencyl.api.engine::GameState/loadScene()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:469]
   at stencyl.api.engine::GameState/begin()[/home/stencyl/stencyl.net/jenkins/jobs/StencylWorks-Dist/workspace/plaf/flash/root/stencyl/api/engine/GameState.as:265]
   at Function/<anonymous>()[C:\Users\stollenwerk\AppData\Local\Temp\stencyl9006857062335622965\sandbox\flash\scripts\MyAssets.as:190]

i have to dismiss all every time i test in flash. i also attatched the logs if you want them:

Alexin

  • *
  • Posts: 3132
It's a dead end. The best I can tell is the problem happens when a behavior is loaded.

Try the following: remove one behavior at a time and test. Hopefully, you find out which behavior is faulty, if any.
"Find the fun"
alexin@stencyl.com

readerboy7

  • Posts: 59
i figured out which behavior it was: the drag and drop, the only behavior i got from stencylforge. ironic, huh?