Dialoge Extension error in options box

moschner

  • Posts: 10
Hey people,
I was following a tutorial by "The Indie station' on YouTube to set up the data structure on the Dialoged extension. I have followed the video like three times know trying to see what I got wrong but cant figure it out  :'( . I can start the dialog but once it comes to the option box I get error #2015. Can anyone help??
this is what appears
ArgumentError: Error #2015: Invalid BitmapData.
   at flash.display::BitmapData/ctor()
   at flash.display::BitmapData()
   at DialogOptions/option()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src-ext/DialogOptions.hx:213]
   at Function/http://adobe.com/AS3/2006/builtin::apply()
   at Function/<anonymous>()
   at DialogBox/executeTag()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src/DialogBox.hx:479]
   at DialogBox/messageStep()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src/DialogBox.hx:388]
   at DialogBox/update()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src/DialogBox.hx:510]
   at Dialog/updateDialogBoxes()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src/Dialog.hx:390]
   at Dialog/dialogUpdater()[C:\Users\lauramoschner\AppData\Roaming\Stencyl\stencylworks\engine-extensions/dialog/src/Dialog.hx:148]
   at com.stencyl::Engine/update()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2408]
   at com.stencyl::Engine/postUpdate()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2610]
   at com.stencyl::Engine/onUpdate()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2603]

TheIndieStation

  • *
  • Posts: 2261
You probably have set the wrong size for one of your scale images. Can you show us a screenshot of your scale images setups?

moschner

  • Posts: 10
Thank you so much  :D you are a life saver and your tutorials are really great!
Here are the screen shots

TheIndieStation

  • *
  • Posts: 2261
I'm glad you like my tutorials =)

Ok, so here is a checklist which can cause the issue:
- You set the scale of a window to be smaller then 10. Since you have a border dimension of 5 and 5, it means you need at least 2 times that size in both X and Y. So make sure your window size is bigger then 10 x 10.
- If you did make the window bigger then 10 x 10, but you also use padding, make sure that you also take that amount into your image size. A padding of 5 x 5 would mean you need a window size of at least 20 x 20. (2 x 5 = 10 window size + 2 x 5 = 10 extra padding.)
- I do remember I had an issue with I believe a scaling out tween, so if you use a tween that scales an image out when destroying a window, try to select another one.

Let me know if this solves anything =)