[IOS/Android] Tapdaq advertising Mediation and Cross Promotion) [v2.2.6]

robinschaafsma

  • *
  • Posts: 652
UPDATE

2017-07-16(2.2.2) Update SDK to iOS:5.3.0 Android: 5.3.0. Required byRobin Toolset Extension Manager(v3)
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



xplosion28

  • *
  • Posts: 247
I was trying to follow your tutorial to publish the .ipa file through Xcode, however when I got to the Game Center section I turned it on but there wasn't a 'Fix Issue' button.  Then when I tried to create the archive of the app, the archive button was grayed off not allowing me to do it.

Never mind I got  the archive button to work, however it can't finish creating the archive due to a compile error:

ld: library not found for -lApplicationMain
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Edit: I figured it out, like I mentioned above there was no "Fix Issue" in the Game Center so when I turned it on, that was what was causing the error and not letting me create the archive.  Although without your guide I would still be scrambling around like a maniac, so thanks again!

« Last Edit: October 30, 2017, 07:13:00 pm by xplosion28 »

robinschaafsma

  • *
  • Posts: 652
UPDATE

2017-12-02(2.2.3) Update SDK to iOS:5.9.1 Android: 5.9.0. Required Required byRobin Toolset Extension Manager(v4) and byRobin Engine manager 0.1.5 For android required Minimum version 16.
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



FMStudioGameDev

  • *
  • Posts: 147
Hi Robin,
I am unable to build for Android since latest update.
Throwing this error:

Code: [Select]
[haxelib] /Users/mcmalela/stencylworks/android-sdk/android-sdk-macosx/tools/ant/build.xml:573: ../google-play-services-gcm resolve to a path with no project.properties file for project /Users/mcmalela/stencylworks/games-generated/MementoCollLASTBK2311/Export/android/bin/deps/tapdaq
Can you please help me? It's quite urgent... Thanks a lot

FMStudioGameDev

  • *
  • Posts: 147
Does anyone have version (2.2.2) to share with me?  I made the stupid mistake to update the extension without saving the previous version and now I cannot build to android.  Thanks

colburt187

  • *
  • Posts: 2182
I can't seem to attach it, file might be too big, email me at colinwlane@gmail.com and ill send it over

FMStudioGameDev

  • *
  • Posts: 147
I can't seem to attach it, file might be too big, email me at colinwlane@gmail.com and ill send it over

Email sent. Thanks a lot mate!

FMStudioGameDev

  • *
  • Posts: 147
Here again looking for help from Robin. Latest version is not working correctly on iOS.
Only AdMob ads are available even if I enabled Applovin/Unity and Vungle by pressing the button in toolset. So no other network works (that results in not having any rewarded ads available).
This screenshot from XCode suggest me that the other frameworks are not included in the package.
Older version sent by Colburt allow me to build for Android but not to iOS (since I guess it requires older versions of ByRobin Extention Manager and Toolset Extensions as well).
Really need a solution to this, I am about to publish and Tapdaq is really the best solution avaible at the moment - when working  :P