Encountered errors while building your game.

yilang

  • Posts: 1
Hi all,

I am new, but I encounter problem at my first step. Anyone can help me?

yoplalala

  • *
  • Posts: 1528
C:\Common\Eclipse Workspace Windows\Stencyl\plaf/haxe/std/neko/Lib.hx line 30
2015-09-13 21:50:04,593 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [neko] Uncaught exception - load.c(237) : Failed to load library : C:\Program Files\Stencyl\plaf\haxe\lib/lime/lime//ndll/Windows/lime.ndll
2015-09-13 21:50:04,593 DEBUG [pool-1-thread-2] stencyl.sw.util.Util: Process 'neko' exited with code: 1


Somehow you cannot load lime.ndll
@TheIndieStation had the same problem http://community.stencyl.com/index.php/topic,43796.msg245452.html#msg245452 maybe see with him how he resolved if he did

danielle53

  • *
  • Posts: 55
very strange ..
I've got the same kind of error :
Code: [Select]
2015-10-13 11:22:45,065 DEBUG [pool-1-thread-1] stencyl.sw.util.Util: Running command: [plaf/neko-linux/neko, /home/dan/Projets/plaf/haxe/lib/lime/lime/tools/tools.n, -verbose, test, -release, project.xml, linux, -openfl, /home/dan/stencylworks/stencylworks/games-generated/G1/]
2015-10-13 11:22:45,212 INFO  [Thread-10] stencyl.sw.util.StreamGobbler: [neko] Called from C:\Common\Eclipse Workspace Windows\Stencyl\plaf/haxe/std/neko/_std/EReg.hx line 200
2015-10-13 11:22:45,212 INFO  [Thread-10] stencyl.sw.util.StreamGobbler: [neko] Uncaught exception - load.c(237) : Failed to load library : /home/dan/Projets/plaf/neko-linux/regexp.ndll (libpcre.so.3: cannot open shared object file: No such file or directory)
Called from C:\Common\Eclipse BUT I am not under Windows !
Some how it is quite normal that this failure to load a library is not seen as an error ...


« Last Edit: November 07, 2015, 07:35:14 pm by danielle53 »

danielle53

  • *
  • Posts: 55
2015-10-13 11:22:45,212 INFO  [Thread-10] stencyl.sw.util.StreamGobbler: [neko] Called from C:\Common\Eclipse Workspace Windows\Stencyl\plaf/haxe/std/neko/_std/EReg.hx line 200
Some how it is quite normal that this failure to load a library is not seen as an error ...
I concede that I felt into thinking that the line 200 of a library that can't  possibly call something was wrong.
Not easy to debug ... when the tracebacks are misleading.
The good thing is somehow this line has disappeared when I update Stencyl,  (8678 was it ?) but that's not a proof by itself..
and upgrading may be not enough ( for myself I have in the meantime manage to clean a little bit my environment, I mean my environment variables

Justin

  • *
  • Posts: 4312
I mentioned this in another thread, but the reason the stacktrace includes a path that's not on your computer is likely because certain binaries were built on mine, so the paths on my computer (C:\Common\...) were baked in to those binaries when they were compiled.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)