[IOS/Android] Heyzap advertising (Interstitial & Rewarded Video) 2.9.3

robinschaafsma

  • *
  • Posts: 712
Ok, thanks.
Hi Christian,

I did not have found the time to look at the Admob problem, sorry. I hope i can find some time soon.

ChristianEs

  • Posts: 226
ok, no problem. (its a problem about admob sending ad requests "forever" when the device has no internet connection) i write this in case someone knows what to do.

« Last Edit: June 24, 2016, 04:44:11 pm by ChristianEs »

jaxszn

  • Posts: 13
If I want to use AdMob on iOS within your Heyzap mediation extension, what should I do to enable Stencyl's built-in AdMob function for iOS? Should I enter in my AdMob interstitial key under "Monetization" even though it says "for Android only."


robinschaafsma

  • *
  • Posts: 712
UPDATE 2.6 available

SDK for both iOS and Android updated to 9.6.8

Max Finch

  • *
  • Posts: 2186
Got an E-Mail stating Heyzap should be updated to version 10 soon to avoid conflicts with iOS 10. Did you get the same E-Mail?

gkhanni

  • *
  • Posts: 252
Got an E-Mail stating Heyzap should be updated to version 10 soon to avoid conflicts with iOS 10. Did you get the same E-Mail?

+1 here. Changed with latest sdk but after did that ads are not working.

robinschaafsma

  • *
  • Posts: 712
Yes, i get the same email, you can't just replace the new SDK with the old one.
In SDK 10 Heyzap is using the best features of Fyber.
So before all the Ad Network can be used the Fyber embeddedframeworks need to be added in each network extension or else it won't work. (There is an Fyper embeddedframework for each Network).

But the SDK 9.6.8 is iOS 10 compatibel
https://developers.heyzap.com/docs/changelog

p.s.
I i am trying to update to 9.6.9 to support Unityads SDK2.0, but i get blackscreens after dismiss. So for unityads users use version 0.0.5 of the unityads extension for now with Heyzap.

gkhanni

  • *
  • Posts: 252
Sorry Robin, couldnt understand exactly steps about Fyber. There is only one Fyber SDK under Heyzap. On the other hand i have to change sdk to stop compile error.

robinschaafsma

  • *
  • Posts: 712
Ok let me say it this way, Heyzap has an Fyber SDK so i i update Heyzap ads will work,

but.... all other Networks like Admob, UnityAds, Vungle etc.. will not work anymore. To let them work with Heyzap with SDK 10 all the Networks need a seperate Fyber SDK in there extension to let them work with Heyzap.
(there are seperate Fyber SDK for each Network.

So if i update it now, i cannot support other networks anymore.. I have to update them to..
So i have to make some free time to update them all, it's not done in 1 day..

I thought i already had fix the  compile error issue.
Yesterday i still could download the old SDK but it seems like today Heyzap only support SDK 10. I attach the SDK i downloaded yesterday from Heyzap, hopes this fix the compile error issue for now unit i update all the extension.

Heyzap SDK 9.6.9:
https://www.dropbox.com/s/hoyd4ol61485e18/heyzap-ads-sdk-9.6.9.zip?dl=0

robinschaafsma

  • *
  • Posts: 712
o and by the way Leadbolt seems not be support in Heyzap SDK 10 anymore..

gkhanni

  • *
  • Posts: 252
o and by the way Leadbolt seems not be support in Heyzap SDK 10 anymore..

Leadbolt has serious troubles nowadays. I am compiling the game with new sdk, hope it works.

gkhanni

  • *
  • Posts: 252
Thanks Robin it is working except Unity Ads.

o and by the way Leadbolt seems not be support in Heyzap SDK 10 anymore..
Leadbolt has very good ecpm for me.=(

gkhanni

  • *
  • Posts: 252
o and by the way Leadbolt seems not be support in Heyzap SDK 10 anymore..
Leadbolt has very good ecpm for me.=(

I suggest that using Applovin instead of Leadbolt for your next projects if Leadbolt does not update themselves.