[IOS/Android] Heyzap advertising (Interstitial & Rewarded Video) 2.9.3

robinschaafsma

  • *
  • Posts: 714
OK I replaced frameworks as instructed, cleaned project, and it built to my phone without any compile errors for the first time. However, the ads don't show up, and when I open the heyzap debug window, it's empty, except for a message, "Fyber Version 8.5.5 - Waiting for SDK to start."

Logs attached. 
It means the Heyzap SDK is not  started, check the initialize block and check your id and/or internet connection.
I need the logs from Xcode instead of Stencyl to see the message.

Did you also tried to run it in Simulator?

robinschaafsma

  • *
  • Posts: 714
Updated byRobin Extension Manager, you have to need version 0.0.8 of the manager to use Hezap extension 2.7.

Quote
Added NSCalendarsUsageDescription  and NSBluetoothPeripheralUsageDescription in Info.plist (needed for publish)

gkhanni

  • *
  • Posts: 252
Updated byRobin Extension Manager, you have to need version 0.0.8 of the manager to use Hezap extension 2.7.

Quote
Added NSCalendarsUsageDescription  and NSBluetoothPeripheralUsageDescription in Info.plist (needed for publish)

It is working thanks.

« Last Edit: November 22, 2016, 12:37:18 pm by gkhanni »

robinschaafsma

  • *
  • Posts: 714
Update available

-2.8 (2016-11-25) Added Banner Support and Android Admob support

Login in to my store and re-download the extension.

For iOS:
Don't forget to replace the Heyzap Frameworks as described here: http://community.stencyl.com/index.php/index.php?topic=45095.msg276220#msg276220

JHKeller

  • *
  • Posts: 38
Does anyone know where in the HeyZap dashboard you go to in order to flag your device for testing? I haven't seen it in publisher settings or any of the other app specific settings.

Thanks! Apologies if I've overlooked something obvious :)

robinschaafsma

  • *
  • Posts: 714
Does anyone know where in the HeyZap dashboard you go to in order to flag your device for testing? I haven't seen it in publisher settings or any of the other app specific settings.

Thanks! Apologies if I've overlooked something obvious :)

Mmm it was before in publisher settings, but it seems not available anymore. So you did not overlooked.
You can always use the debug block to test if the ads are working.

You can contact support@heyzap.com to ask why this option is not available anymore..

JHKeller

  • *
  • Posts: 38
Thanks! I've emailed them. I'll post it here if I figure it out.

Hey Robin!

Downloaded a few of these extensions that you have created, NICE WORK!

I'm currently using the HeyZap extension and I'm getting a compile error. Now I've downloaded your Extension manager along with HeyZap, and I've followed (hopefully) everything mentioned in the steps on your wiki. I believe I'm using the blocks correct as well, however, when it compiles, it comes up with a "[haxelib] ld: symbol(s) not found for architecture i386", and proceeds to say "[haxelib]       objc-class-ref in libheyzap.a(e5b98c46_HeyzapEx.o)".

I've replaced the 'HeyzapAds' with the one you suggested here - 'https://github.com/byrobingames/heyzap/wiki/4.-Error-on-Compiling' in case it could have been that, but it doesn't look like it has fixed the problem :S

I would have attached the log files, but its a large file. I will try to break it in to smaller part if you need them, but I couldn't really find anything else wrong with the compile besides that.

I would greatly appreciate the help n_n

Cheers,
JBG

robinschaafsma

  • *
  • Posts: 714
Hi,
The wiki page is out of date , i still need to  update it..

You must replace all 4 of the frameworks that is listed in the "stencylworks/engine-extensions/heyzap-master/frameworks" folder.
Replace all 4 the frameworks. (Make sure you copy the framework inside the embeddedframework folder and not the embeddedframework folder self)
- Fyber_AdMob_7.10.0-r1.framework
- Fyber_HyprMX_4.1.0.68-r1.framework
- FYBHZMediationTestSuite.framework
- HeyzapAds.framework

Download the the frameworks from this post: http://community.stencyl.com/index.php/index.php?topic=45095.msg276220#msg276220

If you also use Unityads or Applovin or Facebookads or Vungle extension with Heyzap, you must replace the frameworks also in the frameworksfolder of that extension.

EDIT: I have updated the wiki page https://github.com/byrobingames/heyzap/wiki/4.-Error-on-Compiling
Hope this helps.

« Last Edit: December 10, 2016, 11:44:27 am by robinschaafsma »

AWESOME ROBIN!

that did the job! However, now when I go to play the game, it's telling me (this is all in testing by the way) that the 'HeyZap: Reward Video ad (did successfully load)' didn't Load.

I have 'Initialise with 'publisher ID: XXXXXXXX' block right at the start of the load screen when the game starts (inside a do only iOS block)

In the start of the scene, i have 'HeyZap: 'Fetch' Rewarded Video Ad' block active

I have 'if HeyZap: Reward Video ad (did successfully load), then do: Create button. < this is the problem. It's not showing up.

then, when I press that created button in that scene, to 'show' that ad.

I hope this is the set up, however, i'm not sure if testing just doesn't show ads or not.

Side note: my Chartboost extension does not seem to work at the moment, so I could not have that 'enabled'. Hopefully this does not cause any issues.

My publisher ID is the same as on HeyZap accounts, so I dont think it's that.

Cheers,
JBG

« Last Edit: December 10, 2016, 05:55:26 pm by JuicyBeetleGames »

robinschaafsma

  • *
  • Posts: 714
Can you put the debug block under a button and click on it. An new window will open, can you tell me what the content/message in that window is?

If there is this message: Fyber Version 8.5.5 - Waiting for SDK to start Ada will not work.

In general this message just means the SDK hasn't started yet. Solving this usually involves confirming your dashboard settings are correct, making sure the bundle ID of your app matches your dashboard, or contacting support if these things don't work. support@heyzap.com.
Check if your payout information is filled out in your dashboard, if not you can get also above message and ads won't work.

Hope this helps..

Yeah, that's the message I'm getting :S

Ok then, so the dashboard on HeyZap is as followed:

Account Details:
Username: supplied
Publisher ID: Supplied
API Key: Supplied

App Settings:
Name: Supplied
App Store ID: This was grabbed from the iTunes Connect (App Information)
Bundle ID: com.(name).(gamename) < same as every other one I've used/App ID

I've turned off Chartboost because I don't believe it's not currently supported for xCode 8 (from what I've gathered.
I do have Ad Colony active but not blocks are in the game.

However, I have created a 'WildCard' Provisioning profile, however, I don't think it's active for this, nor I dont believe it would have much to do with this?

Hopefully this information has been helpful :)

Cheers,
JBG

robinschaafsma

  • *
  • Posts: 714
Did you have you payout information filled out in under your account?
If not,  fill  this in before you can use Heyzap SDK.

Edit: Chartboost and AdColony are not supporter in the Heyzap extension, see first post for supported nerworks

« Last Edit: December 11, 2016, 04:52:51 am by robinschaafsma »

Ok, so I've set that up, but they still aren't coming up. Is there anything else I can do, or does this take a while for the changes to occur?

Cheers,
JBG

robinschaafsma

  • *
  • Posts: 714
It can take a will I think, but is the message in de debug window gone? If not i suggest you to contact Heyzap support at support@heyzap.com. They can see why its waiting for SDK to start, this is not extension related.

Or there are no ads Available in your region, but I doubt that is the case.