[IOS/Android] Heyzap advertising (Interstitial & Rewarded Video) 2.9.3

robinschaafsma

  • *
  • Posts: 714
Yes, debug block is not working at my side.  So cant be sure is it Applovin or not.

It could not be Applovin if you disable AppLovin.
i am now a bit curious why the debug block is not working on your side.

gkhanni

  • *
  • Posts: 252
Not working. Cleaned the project, put it under actor, put it under scene .. nope

gkhanni

  • *
  • Posts: 252
PS: Android build did not give any error when Applovin is enabled.

robinschaafsma

  • *
  • Posts: 714
Did you already tested in a new game on build 9280?

I am a bit lost because i don't have does errors.. Maybe we can make an Skype Appointment so i can see whats going  on your side.



gkhanni

  • *
  • Posts: 252
Did you already tested in a new game on build 9280?

I am a bit lost because i don't have does errors.. Maybe we can make an Skype Appointment so i can see whats going  on your side.




Nope, let me try that version. Is Applovin working at your side?

robinschaafsma

  • *
  • Posts: 714
Yes is working perfect on my side, no error and issues..

gkhanni

  • *
  • Posts: 252
Deleted everything, re-installed all extensions, stencyl version 9281. Now errors are looks like about heyzap and applovin.

If applovin disabled, still same error about libheyzap.a

« Last Edit: November 19, 2016, 10:41:57 am by gkhanni »

robinschaafsma

  • *
  • Posts: 714
Yeh, it seems like the all of the SDK's are not linked after download, so you have to manually download all the SDK's an put them in the frameworks folder in the right extension. :(

Download the SDK's from below and replace the old one in framework folder of his extension.

Heyzap iOS
1: Download: https://www.dropbox.com/s/zk3en757wc6m3mn/heyzap-unified-sdk-10.2.0.zip?dl=0
2:Unzip and copy both FYBHZMediationTestSuite.framework and HeyzapAds.framework and replace it with the old one in the frameworks folder of the Heyzap extension

AppLovin iOS
1: Download: https://www.dropbox.com/s/yj90682ieyper8u/ios_applovin_3.4.3r1.zip?dl=0
2: Unzip and copy the Fyber_AppLovin_3.4.3-r1.framework that is in the .embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the AppLovin extension

Admob iOS
1:Download: https://www.dropbox.com/s/l6gtmodmufsg7mc/Unified-Platform_AdMob_7.10.0-r1.zip?dl=0
2:Unzip and copy the Fyber_AdMob_7.10.0-r1.framework that is in the .embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the Heyzap extension

UnityAds
1:Download: https://www.dropbox.com/s/wcwcutns4u5nkre/ios_unityads_2.0.2r1.zip?dl=0
2: Unzip and copy the Fyber_UnityAds_2.0.2-r1.framework that is in the .embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the UnityAds extension

HyprMX
1:Download: https://www.dropbox.com/s/imsnqa1kddy69ym/Fyber_HyprMX_4.1.0.68-r1.zip?dl=0
2: Unzip and copy the Fyber_HyprMX_4.1.0.68-r1.framework that is in the SDK 8 /xxx.embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the Heyzap extension

FacebookAds
1:Download: https://www.dropbox.com/s/y0yv0kna0wzm8n1/Fyber_FacebookAudienceNetwork_4.10.1-r4.zip?dl=0
2: Unzip and copy the Fyber_FacebookAudienceNetwork_4.10.1-r4.framework that is in the SDK 8 /xxx.embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the Facebookads extension

Vungle
1:Download: https://www.dropbox.com/s/i1jquqx2x5q1xqs/Unified_Platform_Vungle_4.0.6-r2.embeddedframework.zip?dl=0
2: Unzip and copy the Fyber_Vungle_4.0.6-r2.framework that is in the .embeddedframework folder (so do not copy .embeddedframework it self) and replace it with the old one in the framworks folder in the Vungle extension

« Last Edit: November 20, 2016, 02:45:00 am by robinschaafsma »

gkhanni

  • *
  • Posts: 252
Finally it is working thank you. But when open the debug page; only Applovin is successfully integrated. For unity and admob it says

"NO SDK Detected
The Fyber SDK was unable to locate the SDK for UnityAds inside your application. If you did not mean to integrate this SDK, then this is normal. Otherwise you may have integrated the UnityAds adapter bundle incorrectly. "

robinschaafsma

  • *
  • Posts: 714
Finally it is working thank you. But when open the debug page; only Applovin is successfully integrated. For unity and admob it says

"NO SDK Detected
The Fyber SDK was unable to locate the SDK for UnityAds inside your application. If you did not mean to integrate this SDK, then this is normal. Otherwise you may have integrated the UnityAds adapter bundle incorrectly. "

Because of the same issue with Heyzap and Applovin SDK there are not linked anymore when you downloaded the extensions, don't know why that is, so you need also have to download the Fyber SDK's of Admob and Unityads.
I hav updated the post above with all the download links with all the by me supported Networks .
http://community.stencyl.com/index.php/index.php?topic=45095.msg276220#msg276220

gkhanni

  • *
  • Posts: 252
Unity is done. Just error for Admob.  (in mobile settings it is disabled, enabled in extensions)

robinschaafsma

  • *
  • Posts: 714
Unity is done. Just error for Admob.  (in mobile settings it is disabled, enabled in extensions)

The error says that you have duplicated classes, in this update of Heyzap you have to disable Admob in mobile setting and disable it in extensions. (The Heyzap extension is handling the Fyber Admob SDK).
Because you have enabled in extension you get this error, so disabled it an run clean project.

PS: Admob extension is deprecated.

gkhanni

  • *
  • Posts: 252
Compiling...So that means we can not using Admob banners and Heyzap at the same if we use Admob interstatial&rewarded right?

robinschaafsma

  • *
  • Posts: 714
Compiling...So that means we can not using Admob banners and Heyzap at the same if we use Admob interstatial&rewarded right?

Yup thats right.. but if you want to do this delete the reference to the googleadmob framework in the include file that is in the Admob extension that you use or in the build in Admob and enable it . Then there are no duplication

Edit: I gonna look to support banners with heyzap then this probleem is also solved

« Last Edit: November 21, 2016, 05:42:41 am by robinschaafsma »

Unept

  • *
  • Posts: 352
OK I replaced frameworks as instructed, cleaned project, and it built to my phone without any compile errors for the first time. However, the ads don't show up, and when I open the heyzap debug window, it's empty, except for a message, "Fyber Version 8.5.5 - Waiting for SDK to start."

Logs attached. 
Unicycle Hero: iOS  |  Level With Me: iOS/Android  |  Hue Ball: iOS/Android  |  Lava Bird: iOS/Android   |   Disposabot   |   Twitter