Stencyl 3.4.0 is now out. Get it now!

[IOS/Android] Heyzap advertising (Interstitial & Rewarded Video) 2.9

colburt187

  • *
  • Posts: 1801
Hi Robin, I finally got round to updating everything. Its all working apart from Admob, I see something in the logs about duplicates.

I can build as see ads for unity, applovin and vungle. As soon as i check the admob box it fails to build, logs attached.
Hi,
The duplicates issue is because you have enabled Admob in the Mobile Settings (i can see that in the logs).
To use Admob iOS with Heyzap you have to disable Admob in the mobile settings, or else you get duplicates.
I have Admob for Heyzap build in the Heyzap extension so you don't have to enable it.

See also  first post:
Quote
IMPORTANT
- For AppLovin add your SDKKEY in the include file as described in the Extension.
- For Admob iOS Disable Admob in Mobile Setting.

You can test it with the debug block.

Sorry I missed that info in the first post. So I don't put anything in the admob settings in stencyl, no Unit IDs etc.

colburt187

  • *
  • Posts: 1801
Applovin is working 100% for reward and interstitials.

unity and Vungle are crashing every 2 out of 3 adverts both reward and interstitials. Jungle is showing an Angry Birds 2 advert that crashes 100% of the time, if the advert completes then the app crashes when you press the x to close the advert.

robinschaafsma

  • *
  • Posts: 574
Applovin is working 100% for reward and interstitials.

unity and Vungle are crashing every 2 out of 3 adverts both reward and interstitials. Jungle is showing an Angry Birds 2 advert that crashes 100% of the time, if the advert completes then the app crashes when you press the x to close the advert.

Ok thats the first I hear that.
Is this happen also when using the debug block, or only on the show block it self.

Anybody else have this problem? I don't have this problem so I cannot debug it.

Edit: I see there are some SDK updates available, I will update them asap, hope this will fix the problem for you.

« Last Edit: January 10, 2017, 08:11:40 am by robinschaafsma »
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



colburt187

  • *
  • Posts: 1801
Also a note, this only happens on the iPad mini on 10.0, my iPhone 6 on 10.2 doesn't crash so far. Im updating the iPad mini to see if that helps.

Edit, so updating my iPad stopped the crashing.

« Last Edit: January 10, 2017, 09:58:31 am by colburt187 »

robinschaafsma

  • *
  • Posts: 574
Also a note, this only happens on the iPad mini on 10.0, my iPhone 6 on 10.2 doesn't crash so far. Im updating the iPad mini to see if that helps.

Edit, so updating my iPad stopped the crashing.

Ok Thanks for testing..
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



gkhanni

  • *
  • Posts: 216
Logs attached with Vungle.

robinschaafsma

  • *
  • Posts: 574
Logs attached with Vungle.
Ok Thanks this helps a lot,

Can you do the following for me (if this works i will make an update)
Replace "project.properties" file in "stencylworks/engine-extensions/vungle/dependencies/vungle/" with the one i attach here.
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



gkhanni

  • *
  • Posts: 216
Logs attached with Vungle.
Ok Thanks this helps a lot,

Can you do the following for me (if this works i will make an update)
Replace "project.properties" file in "stencylworks/engine-extensions/vungle/dependencies/vungle/" with the one i attach here.

Thank you. I could create an apk but couldnt try on any device yet.

GuyCockcroft

  • *
  • Posts: 126
Hi. Is there any news on a fix for this? I'm fairly sure my app is crashing when showing vungle ads. (Other ad networks seem to display fine). Thanks!

colburt187

  • *
  • Posts: 1801
Hi. Is there any news on a fix for this? I'm fairly sure my app is crashing when showing vungle ads. (Other ad networks seem to display fine). Thanks!

Is that just Android or iOS aswell?

GuyCockcroft

  • *
  • Posts: 126
iOS only for me.  Not tested Android as yet. Could well be my credentials in the heyzap dashboard though. If I display the debug info ingame  it says that they are bad/missing.

In vungle dashboard, it gives me the same App ID as my Reporting API ID which I thought was weird.

robinschaafsma

  • *
  • Posts: 574
iOS only for me.  Not tested Android as yet. Could well be my credentials in the heyzap dashboard though. If I display the debug info ingame  it says that they are bad/missing.

In vungle dashboard, it gives me the same App ID as my Reporting API ID which I thought was weird.
If the debug info ingame is saying the are bad/missing, you have indeed check the dashboard settings
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



GuyCockcroft

  • *
  • Posts: 126
Thought I'd just let you know about something I discovered. I am able to display Vungle ads directly with the Vungle extension, so my credentials seem fine. But Heyzap was not displaying anything from Vungle. I just found this on Vungle's website though (related to Test/Active Modes):

Test Mode - This is the default mode. Use Test Mode if your app is not yet live in the app store and you want to send test ads to devices. Vungle can send an unlimited number of test ads. You do not earn revenue while your app is in Test Mode. You also cannot link it to any third-party services, such as mediation partners. It is common to see ad repetition in this mode as Vungle cycles through a limited set of ads to your users.
Active - Make sure to set your application to Active if your app is live in the app store. It now shows ads to users and adheres your settings. Active mode is also required if you are using a mediation partner, such as Fyber: your app must be Active for you to link the third-party service.

So, I guess I can't really test Vungle ads via Heyzap until my app is Active on the App store. But at least I've found the source of the problem!


colburt187

  • *
  • Posts: 1801
Thought I'd just let you know about something I discovered. I am able to display Vungle ads directly with the Vungle extension, so my credentials seem fine. But Heyzap was not displaying anything from Vungle. I just found this on Vungle's website though (related to Test/Active Modes):

Test Mode - This is the default mode. Use Test Mode if your app is not yet live in the app store and you want to send test ads to devices. Vungle can send an unlimited number of test ads. You do not earn revenue while your app is in Test Mode. You also cannot link it to any third-party services, such as mediation partners. It is common to see ad repetition in this mode as Vungle cycles through a limited set of ads to your users.
Active - Make sure to set your application to Active if your app is live in the app store. It now shows ads to users and adheres your settings. Active mode is also required if you are using a mediation partner, such as Fyber: your app must be Active for you to link the third-party service.

So, I guess I can't really test Vungle ads via Heyzap until my app is Active on the App store. But at least I've found the source of the problem!



hmmm im not sure about that, I have an unreleased game with hey zap implemented and Vungle is showing in the successfully integrated section and is showing adverts in the debug. In my Vungle page it is set to test ads. What version of Vungle and hey zap are you on?

GuyCockcroft

  • *
  • Posts: 126
I have v0.0.8 of the Extension manager with v2.8 of the Heyzap extension. In the Heyzap-master folder, I have version 4.0.6-r2 of the Vungle framework. Which I don't think is the latest version, but I think I had  compile error when I copied the latest version into there. It's the same version as is in my Vungle extension folder (in engine-extensions) which appears to work.