Class<motion.Actuate> has no field unloadForTarget (Reposted from "Bugs")

djohoe28

  • Posts: 2
After I install Stencyl, use it, test with it, etc., and close it, once I open Stencyl again, it won't compile ANY game. The problem repeats each time I install Stencyl (I install it --> Works the first time --> I close Stencyl once --> It never works again.)

I'm using Build 8734 (3.3.2) right now, but I have tried with the currently available 3.3.0 nd 3.4.0 many a times to no avail.

For the record, this started ever since I installed HaxeFlixel a couple of weeks ago. I have since uninstalled it, but the problem remains.

Here's the (first) error that comes up:
C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/models/Actor.hx:3274: characters 2-25 : Class<motion.Actuate> has no field unloadForTarget

And here's a link to the generated logs, just in case.
https://www.dropbox.com/s/aomnweu0d71sbrc/log-2016-03-11.zip?dl=0

captaincomic

  • *
  • Posts: 6109
For the record, this started ever since I installed HaxeFlixel a couple of weeks ago. I have since uninstalled it, but the problem remains.

Here's the (first) error that comes up:
C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/models/Actor.hx:3274: characters 2-25 : Class<motion.Actuate> has no field unloadForTarget

It looks very much like a leftover from HaxeFlixel is interferring here (maybe a different version of the Actuate library). I would try completely uninstalling Stencyl and anything haxe related and then trying again.