Stencyl, Flash, HTML5, Android and the future

tabletop

  • Posts: 343
Wait so, does this mean we can finally have hardware acceleration because of HTML5?

deatherr1

  • *
  • Posts: 61
They will add hardware acceleration when there ready.
HTML 5 isint the only one with hardware acceleration im guessing you weren't aware Adobe Flash 11 supports hardware acceleration.

System4Studios

  • Posts: 44
Would be almost perfect if they can add in XNA support...
Games:
Pitluff: http://tinyurl.com/8y5uovn
The World of Pitluff (In Development):
http://tinyurl.com/cv39ooj

tabletop

  • Posts: 343
They will add hardware acceleration when there ready.
HTML 5 isint the only one with hardware acceleration im guessing you weren't aware Adobe Flash 11 supports hardware acceleration.

Well if Flash 11 did support it, It certainly wasn't brought to stencyl/I know how to activate it.

Miasmos Games

  • Posts: 878
It's not supported by Stencyl yet as Flixel (the underlying tech) doesn't yet support it. If I remember correctly Jon, or maybe Cole (or another Admin) said that it wouldn't be there for a while as Flixel must support it and then Stencyl has to as well. (Hope all this is right Admins).

Cupcake Bounce

Darkhog

  • Posts: 1243
I understand Android port will be paid as iStemcyl is. But how about H(a)T(e)ML 5?
Do you hate everything that isn't linux based? :P

No, I hate HTML5 for its f***** up syntax. Not as much like XHTML, but still. Besides...
[...]HTML5 is open, man!

OPEN


//edit: And I repeat my question:
I understand Android port will be paid as iStencyl is. But how about H(a)T(e)ML 5?

« Last Edit: November 12, 2011, 09:43:52 am by Darkhog »

There are no impossible things. There is only lack of skills.
Don't click this if your computer has less than 641 kilobytes of RAM.
Stencyl stencyling stencylish stencylers :D

coleislazy

  • *
  • Posts: 2607
It's not supported by Stencyl yet as Flixel (the underlying tech) doesn't yet support it. If I remember correctly Jon, or maybe Cole (or another Admin) said that it wouldn't be there for a while as Flixel must support it and then Stencyl has to as well. (Hope all this is right Admins).

You cannot access the hardware acceleration features of Flash 11 with AS3, so it is not something we can simply add easily.

You have to use one of two special shading languages to use Stage3D: AGAL or Pixel Bender3D. AGAL is a very low-level assembly language which looks like this:
Code: [Select]
m44 op, va0, vc0
mov v0, va1
Needless to say, that isn't user-friendly. Pixel Bender 3D is higher-level, but still not near AS3 (I haven't seen it, just what I've read).

If you're interested in working with Stage3D, there are a number of frameworks that do all the "dirty work" for you. Most are for 3D applications, but Starling and N2D2 are made for 2D content.

Miasmos Games

  • Posts: 878
Oh, my mistake, I must have mis-read that somewhere :/

Cupcake Bounce

Alexin

  • *
  • Posts: 3132
Quote from: Darkhog
No, I hate HTML for its f*** up syntax.
Fixed.
"Find the fun"
alexin@stencyl.com

Rhys

  • Posts: 1046
HTML has a perfectly understandable syntax, same with css and javascript.

Alexin

  • *
  • Posts: 3132
Yes, it has. I was pointing out that HTML5's syntax isn't different than the previous version. So not liking it is silly, unless you don't like HMTL's syntax at all, which is legitimate.
"Find the fun"
alexin@stencyl.com

Darkhog

  • Posts: 1243
For me, HTML ended with 4.01. Newer versions just destroyed everything. I can't use <font> tag anymore. In 4.01 CSS was an OPTION, now it's a MUST. Sure most of browsers still accept <font> tag, but it may change. Also did you ever tried to read jquery's source code? For me only comment is understandable: http://www.dangerdanger.org/wp-includes/js/jquery/jquery.js?ver=1.2.6 .

There are no impossible things. There is only lack of skills.
Don't click this if your computer has less than 641 kilobytes of RAM.
Stencyl stencyling stencylish stencylers :D

Kapser

  • Posts: 83
Although what got me into Stencyl is that it makes flash games, this is some good news!

Rhys

  • Posts: 1046
For me, HTML ended with 4.01. Newer versions just destroyed everything. I can't use <font> tag anymore. In 4.01 CSS was an OPTION, now it's a MUST. Sure most of browsers still accept <font> tag, but it may change. Also did you ever tried to read jquery's source code? For me only comment is understandable: http://www.dangerdanger.org/wp-includes/js/jquery/jquery.js?ver=1.2.6 .
Styles are much more flexible with tags in that they can be easily changed with javascript and can be based off of outsourced css files.

jQuery looks like a big mess of code because they removed all formatting from it to save space.

deatherr1

  • *
  • Posts: 61
If you need any beta testing I would be happy to test the Android version. When it is ready for beta of course.