Android TargetSDKVersion

thechaosengine

  • *
  • Posts: 329
Does anyone know how to change the TargetSDKVersion? I need to get up to 23, Stencyl (build 9170) only allows up to 19.



Cheers!

Justin

  • *
  • Posts: 4530
A later build of Stencyl unlocks up to API 22. 23 seems to be excluded because of an app crash on startup.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

thechaosengine

  • *
  • Posts: 329
That'll have to do then, thanks.

Justin

  • *
  • Posts: 4530
Oh, and you'll need to pull in updates in the Android SDK Manager manually.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

thechaosengine

  • *
  • Posts: 329
Had to bump this, turns out it's required that the latest API is targeted to get featured on the Play Store. Any idea if this can be addressed?

Justin

  • *
  • Posts: 4530
In Settings > Settings > Advanced > OpenFL Settings paste this to overwrite the value you've set in the gui.

I don't know why 23 is disabled, except that there's a comment saying "app crash on startup".

Code: [Select]
<android minimum-sdk-version="9" target-sdk-version="23" />
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

thechaosengine

  • *
  • Posts: 329
Thanks Justin, I'll give it a go and see what happens.

Neotron

  • Posts: 475
I manually changed target sdk to 23 but app still crash on startup. Any chance to  fix this in near future?