[SOLVED] Group - Group Collision unexpectedly firing

shape5hifter

  • Posts: 5
In the attached game, in Scene 1, I have a Group-Group Collision event that should only fire when an Actor of group Bullets hits an Actor of group Enemies.  This is meant for the player's bullets to kill an enemy.

After being spawned an Enemy will fire a bullet of his own.  This bullet is in the group "EnemyAmmo".  When an Enemy fires a bullet he is immediately killed by his own bullet, even though it's not in the Bullets group.  In fact, it doesn't matter what group I set this Actor to (I've tried Doodads, Regions) - this Event still fires and destroys the bullet.

I know there are many other ways to set this up, I'm just really curious why this problem is happening.  Please take a look an let me know what I'm doing wrong.

Thanks!

« Last Edit: September 17, 2016, 04:32:51 pm by shape5hifter »

shape5hifter

  • Posts: 5
Found the problem - I changed the Group for the Enemy Bullet in the Properties tab but didn't change it in the Collision tab.

Why are there two places to set the group? 

Is there a reason to have the group set in Collision tab different than the one in the Properties tab?

Justin

  • *
  • Posts: 4543
Properties tab is for the actor type's overall collision group, and all collisions will default to that group. But you can also specify different groups on a collision by collision basis if desired.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)