Cannot test game on ios device

sketchling

  • Posts: 17
I have done all the provisioning and ID steps in the game settings but when I hit 'test game' button with ios device or simulator, it errors out. Logs say something about a parsing error... have a look at my last reply or the logs.

Cheers
Kim
p.s. I am doing a personal provisioning profile on xcode 8.1, stencyl v9279 trying to run on my iphone 7.

« Last Edit: November 05, 2016, 03:42:41 am by sketchling »

colburt187

  • *
  • Posts: 2392
Hey, are you having issues running the game via Stencyl?

sketchling

  • Posts: 17
I havent been having any issues with the flash player version when I test on that platform. I can check tonight if anyhting got corrupted as I didnt test in flash yesterday, it was all about getting the IOS settings working.

colburt187

  • *
  • Posts: 2392
Yes but you should test your game on iOS via stencyl. Running the game in Xcode is kind of a last resort workaround. You should be able to plug your device in and press test on iOS device.

sketchling

  • Posts: 17
Of course, thats what I was doing. I selected 'ios device' and hit the arrow top right in stencyl. Then when it errored out, checked the logs and it was an error parsing. Then as a test I manually went to the file and tried to open it and got similar response from xcode that I got from the logs. That log I uploaded was from stencyl... i assume the command line xcode end of the stencyl compile.

sketchling

  • Posts: 17
I did have xcode open at the same time... might that have caused any issues? ill try a few things tonight.

sketchling

  • Posts: 17
I re-installed xcode.
I created a completely new game and scene and hit the test game button in stencyl with platform set to ios 10.1 simulator.

I got the same issue, with these lines being the ones I assume to be the important info (from stencyl.sw.util.StreamGobbler):

xcodebuild[3317:19703] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary on line 211. Parsing will be abandoned. Break on _CFPropertyListMissingSemicolon to debug.

xcodebuild[3317:19703] Error Domain=NSCocoaErrorDomain Code=3840 "Unexpected character / at line 1" UserInfo={NSDebugDescription=Unexpected character / at line 1, kCFPropertyListOldStyleParsingError=Error Domain=NSCocoaErrorDomain Code=3840 "Missing ';' on line 211" UserInfo={NSDebugDescription=Missing ';' on line 211}}

and
xcodebuild: error: Unable to read project 'iostest.xcodeproj'.

Project /Users/kimtaylor/stencylworks/games-generated/iostest/Export/ios/iostest.xcodeproj cannot be opened because the project file cannot be parsed.

colburt187

  • *
  • Posts: 2392
Sounds very strange, When testing on device did you try setting the iOS to 8.0?

sketchling

  • Posts: 17
No... I'll try that later.

sketchling

  • Posts: 17
I only have the option for 10.1 under target ios, but minimum set to 8... still same issue. Also with the ios simulators it only gives me the option in in stencyl to use 10.1... thoe others are all greyed out.

ceosol

  • *
  • Posts: 2263
I just tried building on 9281 and started getting the same errors:

CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary on line 211. Parsing will be abandoned. Break on _CFPropertyListMissingSemicolon to debug.

...and the other ones.

I tried again on 9191 and everything is going through like it normally does. The only real difference I notice on the Stencyl interface side was the team name. I found this: https://github.com/CocoaPods/CocoaPods/issues/6100, but doesn't really understand what it all means.

It just finished on 9191 while I was typing with no errors.

Xcode 7.2.1 (7C1002)
El Capitan 10.11.6
Mac Mini 2012