Testing In-App Purchases - Issue!

LarsAsen

  • Posts: 118
Hi guys!

Im getting closer to external testers for my game, but first i want to test my In-App Purchase.
So i´ve followed all the steps in the article: http://www.stencyl.com/help/view/ios-in-app-purchases/

And made a buy-button to try it out.
But when i run it and press the buy-button: absolutely nothing happens. Checked the logs, but can´t find anything.

Tried to delete the app and reinstall it, nothing.
Checked every step again, nothing.
Googled and searched the forum, nothing.

Please help me with this.

I attached the logs, and screencaps of the code.

Best regards


« Last Edit: January 09, 2017, 01:39:41 pm by LarsAsen »


robinschaafsma

  • *
  • Posts: 652
Can you try it without the "player can make purchases" block, just call request in the when created, and look it that is working.
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



LarsAsen

  • Posts: 118
Okay, so i´ve deactivated everything except the "buy product" - still nothing..

I worried it´s something wrong with the connection to the App Store?

It´s wierd that i don´t get any reaction when i press, like "can´t find "SuperPigUnlock" or similar...


colburt187

  • *
  • Posts: 2272
do you have the request info for product ID on the first scene of your game?

LarsAsen

  • Posts: 118
do you have the request info for product ID on the first scene of your game?


Correct, on the Start Scene

colburt187

  • *
  • Posts: 2272
I was just reading your other post and was wondering if its related. Ive never had to turn on the content hosting thing. Why did you have you do that?

LarsAsen

  • Posts: 118
I was just reading your other post and was wondering if its related. Ive never had to turn on the content hosting thing. Why did you have you do that?

Yeah It´s kind of related. I needed to turn that on to get the "waiting for upload"-status.
Otherwise i just get the "Ready to submit"-status.

Screencap is attached

colburt187

  • *
  • Posts: 2272
I might be wrong here but Im not sure the status is relevant. Try turning the content hosting off and testing again.

LarsAsen

  • Posts: 118
I might be wrong here but Im not sure the status is relevant. Try turning the content hosting off and testing again.

Okay i tried but same problem, nothing happens. When i launched the app it gets the error-message from stencyl, log attached.

colburt187

  • *
  • Posts: 2272
Do you always get that error or only when you turn off the iap Content hosting?

LarsAsen

  • Posts: 118
Do you always get that error or only when you turn off the iap Content hosting?

I´ve got the error before, but it´s not always there, so i´ve just ignored it.
For the record i turn the content hosting back on, and got the error.


colburt187

  • *
  • Posts: 2272
So the app still builds to your device but the error just shows up in the logs? what Xcode are you on and what target version do you have in stencyl settings?

try deleting the app from your device then building again.

LarsAsen

  • Posts: 118
So the app still builds to your device but the error just shows up in the logs? what Xcode are you on and what target version do you have in stencyl settings?

try deleting the app from your device then building again.

No, after the "Launch Your App"- message i press  "Ok" then i get the "Encountered error while building your game"-message. (image attached).

Xcode: Version 8.1 (8B62)
In Stencyl (target): minimum 9.0, target 10.1.

I will try deleting the app and rebuild.

Thanks

LarsAsen

  • Posts: 118
Okay so I deleted the app and rebuild but same problem.