Testing In-App Purchases - Issue!

robinschaafsma

  • *
  • Posts: 652
And if i can give you some advice on Admob.

Don't use the 3 blocks in one Event, this will properly give problems and not showing always an ad.

1: Use the initialize block only once when the game is started, like in a load game.
2: Use the show block a few seconds later, this way the ad as time to load first, in your case the ad will not show because the ad has no time to load.
byRobinGames.com


I'am not always on the forum, you can mail me if you have an question. info@byrobin.nl



LarsAsen

  • Posts: 118
Okay, I will try that. Thanks a lot!


AlexVsCoding

  • *
  • Posts: 169
Hey!

I got the same IPv6 issue crop up and from reading your replies on here it isn't absolutely clear how you managed to resolve the issue. Could someone explain how you resolve/fix the error? I too am using admob advertisements and have an in app purchase in my game. Thanks! (Here's what Apple wrote btw!)

From Apple
2. 1 PERFORMANCE: APP COMPLETENESS
Performance - 2.1

We discovered one or more bugs in your app when reviewed on iPad and iPhone running iOS 10.2.1 on Wi-Fi connected to an IPv6 network.

Specifically, there are no ads in the app.

Please run your app on a device while connected to an IPv6 network (all apps must support IPv6) to identify any issues, then revise and resubmit your app for review.

For information about supporting IPv6 Networks, please refer to Supporting IPv6 DNS64/NAT64 Networks and About Networking.

LarsAsen

  • Posts: 118
Hey!

I got the same IPv6 issue crop up and from reading your replies on here it isn't absolutely clear how you managed to resolve the issue. Could someone explain how you resolve/fix the error? I too am using admob advertisements and have an in app purchase in my game. Thanks! (Here's what Apple wrote btw!)

From Apple
2. 1 PERFORMANCE: APP COMPLETENESS
Performance - 2.1

We discovered one or more bugs in your app when reviewed on iPad and iPhone running iOS 10.2.1 on Wi-Fi connected to an IPv6 network.

Specifically, there are no ads in the app.

Please run your app on a device while connected to an IPv6 network (all apps must support IPv6) to identify any issues, then revise and resubmit your app for review.

For information about supporting IPv6 Networks, please refer to Supporting IPv6 DNS64/NAT64 Networks and About Networking.

Hi Alex, of course i will try to help you.

*The last thing that made it work for me was to get my Contracts in Effect. It took around 2-3 days to get them accepted.
Are they in Effect for you? (Agreements, Tax, and Banking).

*I´ve attached pictures of the blocks i am using, for one of my IAP-purchases.

*You can also set up a IPv6 network and try it out on your device. If it does work you can record it and send a link to the video that proofs that it is working.





LarsAsen

  • Posts: 118
Hey!

I got the same IPv6 issue crop up and from reading your replies on here it isn't absolutely clear how you managed to resolve the issue. Could someone explain how you resolve/fix the error? I too am using admob advertisements and have an in app purchase in my game. Thanks! (Here's what Apple wrote btw!)

From Apple
2. 1 PERFORMANCE: APP COMPLETENESS
Performance - 2.1

We discovered one or more bugs in your app when reviewed on iPad and iPhone running iOS 10.2.1 on Wi-Fi connected to an IPv6 network.

Specifically, there are no ads in the app.

Please run your app on a device while connected to an IPv6 network (all apps must support IPv6) to identify any issues, then revise and resubmit your app for review.

For information about supporting IPv6 Networks, please refer to Supporting IPv6 DNS64/NAT64 Networks and About Networking.

Hi Alex, of course i will try to help you.

*The last thing that made it work for me was to get my Contracts in Effect. It took around 2-3 days to get them accepted.
Are they in Effect for you? (Agreements, Tax, and Banking).

*I´ve attached pictures of the blocks i am using, for one of my IAP-purchases.

*You can also set up a IPv6 network and try it out on your device. If it does work you can record it and send a link to the video that proofs that it is working.






Sorry i just noticed in your answer from apple "Specifically, there are no ads in the app. "

* Did the ads show when u tested it on your device? Did u remember du unblock the "Enable test ads" in Settings?

johnjanowskibsc

  • *
  • Posts: 23
Hi,

So after a lot of reading and testing I cannot get my ads to pop up when I want or get a Remove Ads button to work. I have gone through all the steps on both Stencyl, admobs and Apple connect.

Is there someone willing to give up some of their time to walk me through how to get this over the line? I feel I'm ever so close but can't put my finger on what needs to be done to finish it off! Any help would be greatly appreciated.


colburt187

  • *
  • Posts: 2256
yeah i can help. First thing, put the request info for the iap in a when created event in the first scene.

Lets see a screenshot of the admob info you have in the settings under moneitization.  Or actually I see you have it there, remove the 'when player can make purchase' bool surrounding it.

johnjanowskibsc

  • *
  • Posts: 23
Ok will have a go at your suggestion.

Quick question. Will the in app purchase and ads show up when testing on the iOS simulator on the Mac?

FMStudioGameDev

  • *
  • Posts: 172
Quick question. Will the in app purchase and ads show up when testing on the iOS simulator on the Mac?
Usually admob shows a test ad on iOS simulators while in-app purchase do not work.

johnjanowskibsc

  • *
  • Posts: 23
Hello. I’ve got the ads to work just by taking out the if adspurchased = false statement.

I will endeavour with the in app purchase to remove ads. If anyone has any actual screen shots of their code then I think that would be most helpful.

Thanks

John

colburt187

  • *
  • Posts: 2256
Here is my set up, I request the info in the first scene, then I have the buy logic on a button, then I check to see if the iap has been purchased before I show an advert.

johnjanowskibsc

  • *
  • Posts: 23
Many thanks. I’ve not had a chance to test this but will let you know when I am successful!

John

johnjanowskibsc

  • *
  • Posts: 23
Hi Coburt,

Many thanks for the screenshots. So much simpler and easier to follow than the guidance on the Stencylpedia page. It worked first time!

Thanks for taking the time to help

John