How to Install for Stencyl 3.4

NuggetsaidNO

  • Posts: 2
So I posted this before but Justin told me if I had any other problems I should post it here. I did everything he said and I'm using 3.4 stencyl.  It's still says the same thing, im very confused can you please help.

« Last Edit: February 02, 2018, 09:17:23 am by Justin »

Justin

  • *
  • Posts: 4099
http://www.polydes.com/3.4.0-extensions/

Take the following files

engine-extensions/com.polydes.datastruct.zip
engine-extensions/com.polydes.dialog.zip
extensions/com.polydes.common.jar
extensions/com.polydes.datastruct.jar
extensions/com.polydes.dialog.jar

Put them in your stencyl workspace. You can find it by opening Stencyl and going to Debug > View > View Workspace Folder.

The .zip folder should be extracted. Make sure you only get one folder, not multiple layers of folders, and it's named correctly. If you did it right, the following paths should be valid.

stencylworks/engine-extensions/com.polydes.datastruct/blocks.xml
stencylworks/engine-extensions/com.polydes.dialog/blocks.xml

Just move the .jar files.

stencylworks/extensions/com.polydes.common.jar
stencylworks/extensions/com.polydes.datastruct.jar
stencylworks/extensions/com.polydes.dialog.jar

Reload Stencyl and try it out.

You can use the sample game to start with. Grab that from the link above in the sample-games folder. Import it to Stencyl by dragging it into your games library.

You can watch TheIndieStation's tutorial series for more, and you can search/browse this forum as well.

http://community.stencyl.com/index.php/topic,40279.0.html

For Live Support: Join our discord channel and ping me @justin.

NuggetsaidNO

  • Posts: 2
Thank you, it worked well! But for some reason using a repositry it says "ouch this should not have happened "

Justin

  • *
  • Posts: 4099
The repository is broken for 3.4.

For Live Support: Join our discord channel and ping me @justin.

EducativeApps

  • Posts: 7
http://www.polydes.com/3.4.0-extensions/

Take the following files

engine-extensions/com.polydes.datastruct.zip
engine-extensions/com.polydes.dialog.zip
extensions/com.polydes.common.jar
extensions/com.polydes.datastruct.jar
extensions/com.polydes.dialog.jar

Put them in your stencyl workspace. You can find it by opening Stencyl and going to Debug > View > View Workspace Folder.

The .zip folder should be extracted. Make sure you only get one folder, not multiple layers of folders, and it's named correctly. If you did it right, the following paths should be valid.

stencylworks/engine-extensions/com.polydes.datastruct/blocks.xml
stencylworks/engine-extensions/com.polydes.dialog/blocks.xml

Just move the .jar files.

stencylworks/extensions/com.polydes.common.jar
stencylworks/extensions/com.polydes.datastruct.jar
stencylworks/extensions/com.polydes.dialog.jar

Reload Stencyl and try it out.

You can use the sample game to start with. Grab that from the link above in the sample-games folder. Import it to Stencyl by dragging it into your games library.

You can watch TheIndieStation's tutorial series for more, and you can search/browse this forum as well.

http://community.stencyl.com/index.php/topic,40279.0.html

Hi Justin
what happened to the link, can't acces it ?!

cetra777

  • Posts: 1
Hello Justin,

Thanks for answering in a step by step format how to install on 3.4. I took me about half of an hour to find this post and then only 5 or 6 minutes to follow the instructions. Cheers!

AlexFreeman

  • Posts: 3
I have everything as stated above but when I build the test game included in the repository says that it encoutered errors. What could I do to fix it?

Justin

  • *
  • Posts: 4099
Post your logs so I can see the errors (Debug > Logs > Generate Logs).

For Live Support: Join our discord channel and ping me @justin.

AlexFreeman

  • Posts: 3
Sorry for the delay, here are the logs

Justin

  • *
  • Posts: 4099
I see. It's tripping up on your Windows username. Same as this problem.

As I mentioned there, you can fix this my changing your Stencyl workspace to a folder outside of your Windows Users folder.

For Live Support: Join our discord channel and ping me @justin.

AlexFreeman

  • Posts: 3
Thank you  :D

This has also recently given me problems installing Anaconda and Atom... Time to change things in my computer!

pandaaz

  • Posts: 1
Hey Justin,
    First of all thank you for the fantastic dialog program it has been very convenient to use but after installing it i have been running into a problem where anytime i use punctuations like periods and question marks i would get an error in the game that says:
TypeError: Error #1009: Cannot access a property or method of a null object reference.
   at dialog.core::DialogFontInfo/getOffset()[C:\Users\callw\AppData\Roaming\Stencyl\stencylworks\engine-extensions/com.polydes.dialog/src/dialog/core/DialogFontInfo.hx:304]
   at dialog.core::DialogBox/messageStep()[C:\Users\callw\AppData\Roaming\Stencyl\stencylworks\engine-extensions/com.polydes.dialog/src/dialog/core/DialogBox.hx:422]
   at dialog.core::DialogBox/update()[C:\Users\callw\AppData\Roaming\Stencyl\stencylworks\engine-extensions/com.polydes.dialog/src/dialog/core/DialogBox.hx:604]
   at dialog.core::Dialog/updateDialogBoxes()[C:\Users\callw\AppData\Roaming\Stencyl\stencylworks\engine-extensions/com.polydes.dialog/src/dialog/core/Dialog.hx:447]
   at dialog.core::Dialog/dialogUpdater()[C:\Users\callw\AppData\Roaming\Stencyl\stencylworks\engine-extensions/com.polydes.dialog/src/dialog/core/Dialog.hx:168]
   at com.stencyl::Engine/update()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2415]
   at com.stencyl::Engine/postUpdate()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2618]
   at com.stencyl::Engine/onUpdate()[C:/Program Files (x86)/Stencyl/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2611]

Clover10123

  • Posts: 11
The repository is broken for 3.4.


So, this post is a year old, and I seem to be having trouble getting this extension to work on 3.4. Is it still broken? Has it been fixed? If so, how can I update my extension?

The extension appears on Stencyl, but it doesn't have any code blocks inside it.


Edit: Never mind. I'm just stupid.

« Last Edit: May 22, 2018, 07:34:34 pm by Clover10123 »

peterson

  • Posts: 4
Will the dialog extension work on 3.5?

Justin

  • *
  • Posts: 4099

For Live Support: Join our discord channel and ping me @justin.