How to Install for Stencyl 3.4

Biiiscoito

  • Posts: 21
Hi, Justin! I've been following up the posts on this forum for about 3~4 months, and I still haven't been able to download the resources using the link provided on the second post . Is the website still down/down again? How should I proceed? I'm using Stencyl 3.4. Thanks!

Justin

  • *
  • Posts: 4354
The site must have gone down again. I've brought it back up. Dunno why I have so much trouble with this server. :\

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

Biiiscoito

  • Posts: 21
Well, that was a strange server indeed! Thank you so much for bringing this back. I hope to get my brain and hands testing and playing with it ASAP!!

DETERMINATOR20

  • Posts: 3
Hi Justin,

When you said in the first thread you sholdn't get multiple layers i the .zip files, did youmean not to get lots of folders? Because that's what has happened to me. Do I just put all the files in, or just some of the? Also, the preview for your dialog extensions looks AMAZING thanks for creating it.
*EDIT* Also, with stencyl 4.0 which was recently released, do the extensions work?

DETERMINATOR20

« Last Edit: January 17, 2019, 12:31:26 pm by DETERMINATOR20 »

Justin

  • *
  • Posts: 4354
You don’t need to worry about this with the latest release. Just follow the instructions on the site. Add the polydes.com repository in Stencyl and install from there.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

Hello Justin. I really thought if I install the files and put them in the folders, I thought everything will be okay. I did try everything under the book to get the 3.4 extensions and then I get the dailogs of missing "style" format, plus the two extensions missing, even though I installed the blocks and made it clear as possible. I still don't know if I take in the resources or is it some sort of glitch? And I'm taking it off beta 3.4.0

Update: Actually I found the reason is that I didn't update the dialogue extension and now I did everything right and I didn't need to go a step ahead for the dialogue thing to work. Everything works now, and I find it great!

« Last Edit: January 18, 2019, 01:42:45 pm by PurpleKingCrazy »

DETERMINATOR20

  • Posts: 3
Hi Justin,
I’m having trouble with using the Dialougue pack. I downloaded it using the repository, and it downloaded fine. But as soon as a tried to use it, it said “ouch this should not have happened” it then let me use it without error. But then when a tried to insert the block of code into something, there was no section for the system (I looked under extensions). The code system worked fine before 4.0 came out. I appreciate all your work and thank you for it.

HelloComics

  • *
  • Posts: 73
I'm dying to try 4.0 but I'm afraid about the Dialogue extension as I use it a lot.
Can you guys confirm it's working in 4.0?

Justin

  • *
  • Posts: 4354
It works. You need to update it through the extension repository.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

HelloComics

  • *
  • Posts: 73
Thank you, Justin! i'll try it out soon.

andriamihaja

  • Posts: 3
Hey ,I really need the version 3.4 of dialog extension,the link doesn't work,so I want someone to send me this by mail please: steefiyandriamihaja@gmail.com
sorry for my bad english,I'm french

Chrysoula

  • Posts: 1
This repo is down.

Justin

  • *
  • Posts: 4354
Thanks, it's back up again.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

HelloComics

  • *
  • Posts: 73
Hello,

I just found the Dialog Extension did not work for me when updating. Could you please help me out in this case?

Edit: The game compiled successfully with the extension, but it crashes every time a "show dialog" block is executed. I'll have to go back to the previous version for now.

« Last Edit: November 20, 2019, 02:33:15 pm by HelloComics »

NickamonPoppytail

  • Posts: 1091
Hi,

I'm currently using Build 9300, and I followed the instructions Justin posted at the beginning of this thread. I have imported the sample game into Stencyl, however, I get the following messages when I open it in the Stencyl software:

Warning
Missing engine extension
The engine extension 'com.polydes.datastruct' does not exist. Do not save the game, if you have used blocks from the extension.

Warning
Missing engine extension
The engine extension 'com.polydes.dialog' does not exist. Do not save the game, if you have used blocks from the extension.

I assume these messages are referring either to the .jar files or the .zip folders. Both .jar files with those names are in the  workspace folder, and so are the .zip folders (both in extracted form as regular file folders, as well as the original .zips). I tried removing the .zips from the workspace folder and leaving the extracted folders, but I still get the same result.

Does anyone know what I'm doing wrong?

Edit: Nevermind. I read this: https://github.com/justin-espedal/polydes/blob/master/Dialog%20Extension/guides/getting_started/guide.md and stuffed around for a bit and managed to get things working

« Last Edit: November 30, 2019, 07:46:56 pm by NickamonPoppytail »
Upcoming Projects
Poppytail 5 and Pixeltail: Fifth and sixth main instalments in Poppytail series. A Game About Trimming Hedges: Final Version: An updated version of the original AGATH; also canon to the Poppytail series. Easter Fun 2: A sequel to the original Easter Fun. One Million: Last-one-standing style small project; also canon to the Poppytail series. The Poppytales: Hand-drawn spin-off bullet-hell RPG using characters from all my other book and game projects. Not canon to the Poppytail series. Skies n' Fall: Boss rush shooter sequel to Rise n' Brawl.