Stencyl 3.4.0 is now out. Get it now!

Cannot Export and Test Game to Flash (both player and browser)

jaypatvin95

  • Posts: 2
Hi,

I am using Stencyl 3.4.0b300 with an operating system of Mac OS High Sierra. My problem is that when I try to test the first and second Crash Course using either Flash browser or player, it says that it "Encountered errors while building your game." I tried publishing and testing it in both HTML5 and Mac (with Xcode) and it works. Attached is the generated Stencyl log. The only problem I can see from the log files is "The input swf newgrounds.swf is corrupted."

I tried searching for a solution in the forums and in Google but to no avail.

Thanks for the replies!

colburt187

  • *
  • Posts: 2130
And are you not using any of the new grounds blocks in the game?

NickamonPoppytail

  • *
  • Posts: 492
If you press the 'Okay' button, sometimes it keeps going. I get a message like that every time I test a game, and for me it only takes 1 or 2 times for the game to work. I'm sorry, but I don't know how to fix this.

jaypatvin95

  • Posts: 2
And are you not using any of the new grounds blocks in the game?

I don't think I am. All the things I'm using are from the Crash Course 1 and 2.

If you press the 'Okay' button, sometimes it keeps going. I get a message like that every time I test a game, and for me it only takes 1 or 2 times for the game to work. I'm sorry, but I don't know how to fix this.

I tried for several times but to no avail.

designpeg

  • *
  • Posts: 535
i'm having the same issue, I dont think I'm using any of the newgrounds blocks, but maybe I am - does anyone know which blocks use newgrounds?

ceosol

  • *
  • Posts: 2151
I received this error after upgrading to High Sierra using build 9300 (3.4 release). The only fix I have is using one of the private beta builds. I think an even better solution is downgrading from High Sierra to another OS.

Steven70

  • *
  • Posts: 42
Mhhh, is this issue solved? I have same problem with High Sierra...no updates to stencyl are planned to solve this problem?

designpeg

  • *
  • Posts: 535
Still not fixed. It's pretty frustrating knowing that this is solved in the beta version (v.3.5), but that the fix hasn't been applied to the version people are paying to subscribe to (v.3.4).  High Sierra was released at the end of September.

Steven70

  • *
  • Posts: 42
Sorry, but you cannot download v.3.5? I'm thinking to pay as INDIE to solve this issue...

designpeg

  • *
  • Posts: 535
I can download 3.5 Steven70, I pay studio, (and have for about 4 years I think), but currently, there are too many issues for me with extensions and my custom code that won't work in 3.5 until I have time to make the changes to my app. So I need to stick with 3.4 at the moment.


designpeg

  • *
  • Posts: 535
But 3.5  may be the best option for yo. Up until 3.5 I religiously downloaded the latest beta, as Justin does a great job of fixing things as they come up. It's well worth the money.