Game runs fine on Mac but crashes after starting level on iOS

nicktendowii

  • Posts: 136
Has something changed with the latest update with regards to iOS? I can run the game fine on Mac but when running it on iPhone it crashes as soon as you begin a level. I’m not sure what could be causing it I’ve tried removing some code blocks and trying different scaling settings but nothing’s working. As as the game installs fine there’s no error logs to check either.
Thanks

colburt187

  • *
  • Posts: 2249
Are able to run the game in flash? or does mac give real time logs? I've noticed some errors crash iOS but not flash etc.

NickamonPoppytail

  • *
  • Posts: 1020
Are able to run the game in flash? or does mac give real time logs? I've noticed some errors crash iOS but not flash etc.

If you are testing the game in Flash, you'll have to convert all of your audio files to MP3s.
046 121 116 105 116 110 101 100 105 032 121 109 032 116 117 111 098 097 032 110 111 105 116 115 101 117 113 032 111 110 032 101 118 097 104 032 100 108 117 111 104 115 032 117 111 089 032 046 084 074 032 101 114 097 032 115 108 097 105 116 105 110 105 032 121 077 032 046 117 111 121 032 107 099 097 116 116 097 032 108 108 105 116 115 032 108 108 105 119 032 073 032 100 110 065 032 046 116 114 105 104 115 032 115 105 104 116 032 103 110 105 114 097 101 119 032 108 108 105 116 115 032 109 097 032 073 032 046 110 111 115 032 115 105 104 032 109 097 032 073 032 046 101 109 032 119 111 110 107 032 121 097 109 032 117 111 089

nicktendowii

  • Posts: 136
The game runs fine in flash and on mac but on iOS it just keeps crashing. I really can't figure out why.

colburt187

  • *
  • Posts: 2249
If you have the log viewer open when running the game in flash, no errors show up?

nicktendowii

  • Posts: 136
If you have the log viewer open when running the game in flash, no errors show up?
no, no errors at all, just the stuff I've set to appear in the log to test like score / lives etc

bonzero

  • *
  • Posts: 487
same problem here, no idea what could be happening, I tried everything, disabling behaviours, drawing blocks, tile blocks, executing minimal code.. but it always crashes= get a black screen-->crash a few seconds later.

My game worked well with previous builds (9520) but since I updated to more recent ones, I don't know but the crash will always happen (I also tried b9689). I tried running in debug mode as Justin suggested on Discord but I always get a message: CPU not supported (tried with iPhone 6,6s,X)

On top of that every time I run on the iOS device, it takes 30min or more to run because it recompiles everything overtime, despite that I've tried all I could
I've been stuck for more than 1 week, and I really needed to publish 1 update to the app...:(

bonzero

  • *
  • Posts: 487
and like nicktendowii mentioned, the game runs perfectly on Mac/ccpia, like it always did, except this time, it crashes on iOS

nicktendowii

  • Posts: 136
and like nicktendowii mentioned, the game runs perfectly on Mac/ccpia, like it always did, except this time, it crashes on iOS
Glad i'm not the only one having this problem! It sounds like exactly the same thing. does the game load up for a split second them sort of stutter and freeze then crash after a while? I've started trying to reduce the file size but it's not making any difference. Like you I was hoping to submit it to apple a few weeks ago but all these issues have stopped me being able to :(

colburt187

  • *
  • Posts: 2249
what about trying to roll back to an older version of stencyl and Xcode?

nicktendowii

  • Posts: 136
what about trying to roll back to an older version of stencyl and Xcode?
I did that and it runs fine but wouldn't work with a splash screen and apple rejected the app because of that..  which is why I updated the programs in the first place.

colburt187

  • *
  • Posts: 2249
Ah yeah I remember the weird loader thing showing instead of a splash screen. If you want to send me the game file I can see if I can get it to build and run.

nicktendowii

  • Posts: 136
Ah yeah I remember the weird loader thing showing instead of a splash screen. If you want to send me the game file I can see if I can get it to build and run.
Thanks, just sent you a message :)

bonzero

  • *
  • Posts: 487
Rolling back is not an option since the splash screens issues and icon at 1024x1024 were fixed later, both needed for publishing. I also tried compiling from 2 different macs, same result :s

colburt187

  • *
  • Posts: 2249
Were those issues for Xcode 9? I submitted an app a few weeks back with Xcode 8 and stencyl 3.4 due to release dec the 7th, cleared review no problems.