Long compile times

bobbyck

  • *
  • Posts: 124
Hi,

I updated on my mac stencyl, xcode and my OS version to the newest versions.

Now everytime I compile it always takes a very long time (5 to 15 minutes). It used to be first compile took long, and then after that every compile was a minute or so -- now every compile is 5 to 15 minutes.

Any ideas?

Thank you!

bobbyck

  • *
  • Posts: 124
I decided to do a reinstall of Stencyl/xcode etc to help with this issue (and others, i.e. non-working physics, randomly on compiles telling me SDK is not found, etc). Everything works fine now, compiles are normal, physics are working, various random errors have all disappeared. The only issue now is that I can not see any "IOS Simulators" options in Stencyl.

"IOS Simulators" is there in the dropdown menu, with an error pointing to the side where you would choose the version, but no options in the submenu.

Compile to MAC, CPPIA, export to IOS all seem to work fine, just no simulator options.

In xcode the simulator v11.1 under "Xcode->open developer tool->simulator" opens and runs fine.

Any ideas?

bobbyck

  • *
  • Posts: 124
As I've been struggling two weeks to get stencyl to work properly, i decided to format my mac today. Clean install of the OS, Java, Stencyl, Xcode, Xcode simulator components.

And after that, still having the same issue. No simulators are showing up to test with.

Justin

  • *
  • Posts: 4313
I'll look into it today.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

Justin

  • *
  • Posts: 4313
Oh by the way, check if the simulators show up under the "Run" menu. Perhaps they're there but not under the quick testing menu.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

bobbyck

  • *
  • Posts: 124
Okay,

On the latest stable build IOS simulators do not show up. I'm guessing this is some kind of compatability issue with the latest xcode.

On the latest nightly build, IOS simulators work fine, however each compile/re-compile takes 15 to 20 minutes (even when there are no changes in the project, ie an empty project file with a blank scene).

Compile to MAC work as normal (under a minute after the 1st compile)

« Last Edit: November 18, 2017, 12:13:39 pm by bobbyck »

Justin

  • *
  • Posts: 4313
Right. Xcode 9 changed some stuff around again so the simulators are only recognized in Stencyl's nightly builds.

So it sounds like the only thing to look at is long rebuilding compiles. And iOS only? Interesting.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)

bobbyck

  • *
  • Posts: 124
Terrain+tiles are broken in the latest nightly build.

i.e.
Square terrain do not maintain their x,y position in a scene, they all move to the top left of the screen/scene.
Polygonal terrain maintains their x,y position, but they do not maintain their shape. i.e some sides of the shape are missing.
Circular terrain seems fine.

A row of about 10 square tiles in a row, they all merge into a  single block on compile, with the exception that the first tile is a merged as a triangle instead of a square.



In the latest stable build (9300) the above is not an issue and terrain/tiles work properly.



« Last Edit: November 19, 2017, 01:04:59 am by bobbyck »