Admob Interstitial Ads

bobbyck

  • *
  • Posts: 124
Hi,

I'm trying to setup interstitial ads and for the life of me, I can't figure out what I'm doing wrong.

1) In settings -> monetization I have "admob ads" enabled and "test ads" enabled.
2) Under Interstitial key I have entered the admob key "CA-APP-PUB-X/X".
3) In the loading scene of my project I have the block "Initialize admob ads with APP ID CA-APP-PUB-X~X"
4) In the gameplay scene, when it is created, I have the block "load admob fullscreen ad"
5) I have an event to go off after 30 seconds "show admob fullscreen ad" but nothing shows.

Am I doing something wrong?

Thank you for any help!



colburt187

  • *
  • Posts: 2389
Its been a while since i used admob only ads so the set up has changed, it looks right, Although I remember people in the past having issues with putting the Ids in the wrong slots. Maybe for testing its easier to remove the counter and load the ad on the title screen the show the ad on a button press or when a scene is opened.

A couple of things to try, put the loading of the advert in a 'do after 0.2' block.
draw the 'advert loaded' block to the screen to see of it actually loads.

RozekEnhance

  • Posts: 46
 If you are having issues with the integration of your ad network, I would suggest that you look into using Enhance to be sure there are no issue with the implementation.  Integration can be a big pain and take up too much valuable time.


 Using Enhance┬«, you can now integrate all of the services that different providers offer without ever having to touch an SDK again.  With little to NO coding at all and without touching source code, Enhance┬« is the easiest way to  integrate 3rd party services into your project or to keep them up to date. (Ads, Mediation, Analytics, Attribution, Crash Reporting and more) No more SDK integration!!!

Implement & update multiple SDKs in a few simple steps with Enhance : https://goo.gl/ZK5td2




« Last Edit: February 09, 2018, 09:10:41 am by RozekEnhance »

capitanox

  • Posts: 34
when load first scene give it for 4 sec to 5  when created do it after 4 sec less than 4 it will not work bro  then u should use block of click when  click  load and show ..  i had hard time too but after searching its work like a charm now

bobbyck

  • *
  • Posts: 124
Thanks for the pointers.

@capitanox,

can i ask what version of stencyl are you using?

capitanox

  • Posts: 34
I back to 3 .4 more stable in my point of view