[SOLVED]Cannot test scene.

Captain Stoudt

  • Posts: 41
Getting the following error:
Events for 'Level1': Unexpected Region
   from scripts.SceneEvents_0
   line: 75
   columns: 19-25

I don't have any events attached to the referenced scene. Any ideas?

« Last Edit: January 10, 2018, 10:23:35 am by Captain Stoudt »

colburt187

  • *
  • Posts: 2230
You don't have any code in the scene events? or any behaviours attached to it?

NickamonPoppytail

  • *
  • Posts: 934
There is no code with reference to a deleted region?
Currently developing Poppytail 5, Pixeltail, The Poppytales, and A Game About Trimming Hedges.

Email: nick.rosemarygames.poppytail@gmail.com

;)

Captain Stoudt

  • Posts: 41
I was adding code to a referenced region, but decided to make it a behavior so that I could use it in other scenes without having to remake it so I deleted the code in the events but when I did that, it's like it didn't delete it from the scene's actual code, just the events section. I can't even test other scenes because of it. SHould I just delete the messed up scene and re-create it?

colburt187

  • *
  • Posts: 2230
Sounds strange but if it's not too much work it may be worth trying deleting the scene. Are you store the error is not coming from the behavior?

Captain Stoudt

  • Posts: 41
Yes, I've even tried deleting all the behaviors. I really don't care to re make the scene, but I also want to figure this out just for the learning aspect of it. Also, the error clearly states that the error is in the scene's events and the events tabs opens after hitting 'ok'. I'm guessing deleting the scene event didn't happen correctly so it didn't remove all of the code that was there. Is there a way to see a scene's code like you can for behaviors?

colburt187

  • *
  • Posts: 2230
Are you using stencyl 3.5? If he issue is what you think then it sounds like a bug with the engine. You could maybe try cleaning the project, if you are using 3.4 then I think it's under Run-clean project from the top menu bar.

Captain Stoudt

  • Posts: 41
3.4 I ran a clean on it but that didn't fix the issue.

colburt187

  • *
  • Posts: 2230
If you want me to have a look you could attach the game file here or email it to colinwlane@gmail.com

Captain Stoudt

  • Posts: 41
So I found out how to view the code for the scene, but I can't edit it. There's obviously still code here for spawning the actor in the region. It turns out, these were from the attributes I had created before. I removed those and now the scene works! Such a simple fix, but I didn't even think to check the attributes. Good learning experience. lol

Captain Stoudt

  • Posts: 41
Thanks for the help though!