Upgraded Now No Simulator Options

brvids

  • Posts: 339
I upgraded to Xcode 9.2 and stencyl 3.4 and now I have no simulator options. They simply aren't there. I scroll to the simulators menu and get nothing.

brvids

  • Posts: 339
Attached is an image. No simulators show up whatsoever, it's just blank. Need some help.

brvids

  • Posts: 339
Hello support??? Anybody from Stencyl team have any ideas?

FMStudioGameDev

  • *
  • Posts: 178
Hello support??? Anybody from Stencyl team have any ideas?
There are plenty of posts in the forum about this.
Stencyl 3.4 does not work with Xcode 9.2, you need to download Stencyl 3.5beta.

bobbyck

  • *
  • Posts: 116
Hi.

I understand your frustration. From my experience, Stencyl 3.4 doesn't work with xcode 9.2 and I had to downgrade xcode to get simulators to work.

I managed to downgrade mine following the instructions here: https://stackoverflow.com/questions/31011062/how-to-completely-uninstall-xcode-and-clear-all-settings

Basically, I uninstalled XCODE, and then to clean up all the remaining XCODE files,  I copy/pasted this line in the terminal program:

rm -rf /Applications/Xcode.app /Library/Preferences/com.apple.dt.Xcode.plist ~/Library/Preferences/com.apple.dt.Xcode.plist ~/Library/Caches/com.apple.dt.Xcode ~/Library/Application Support/Xcode ~/Library/Developer ~/Library/Developer/Xcode ~/Library/Developer/CoreSimulator

After that, I downloaded an older version of XCODE (8.3.2) from the Apple Developer website: https://developer.apple.com/download/more/

8.3.2 Supports up to IOS 10.3.

I am unsure what the maximum version of xcode can be supported by stencyl 3.4.

I hope this helps.