What version of Android/IOS should I compile to?

bobbyck

  • *
  • Posts: 124
Hi,

I'm ready to do a final compile for a mobile project in Android/IOS and would really appreciate if anybody can give me some insight into what the minimum/target versions of Android and IOS I should aim for.

Currently I'm on Stencyl 3.4 b9300.  My Mac pc is high sierra and xcode is v8.3.2 which supports upto IOS10.3. I've tried upgrading 2 months ago to the Stencyl 3.5beta, for both win10 and macos,  but that didn't end well. So, I have reverted back to 3.4.

In Stencyl 3.4 for android, I have minimum 19,  target version 22. Would this be suitable? 

For IOS, my project is minimum version 9.0 and target 10.3. Xcode 8.3.2 supports up to IOS 10.3. Would this be suitable? One of the simulators does pop up a message that this version of IOS is outdated. I also guess that it wont work on Iphone 8 / 8 Plus / X or some of the newer Ipads. And I have no idea anyways if a build from Stencyl 3.4 would work on those devices anyways.?

Does anybody know the highest version of Xcode that Stencyl 3.4 supports? Should I try to install XCODE9.0 to get IOS11? Should I install Stencyl 3.5Beta? (and have any of you successfully published with the 3.5beta?)

Any insight would be much appreciated.

Thank you.

« Last Edit: February 03, 2018, 01:09:31 pm by bobbyck »

Justin

  • *
  • Posts: 4310
Until you're ready (or Stencyl's ready for you) to update to 3.5, yeah, those are the highest versions. Xcode 9+ won't work well with the public release of Stencyl.

For Live Support: Join our discord server and ping me @justin.
I'm most often available between 8am and midnight Japan time. (GMT+9)